Illegal state exception when trying to run first tutorial code

Hello all!

I went through all the stepps outlined in to set up the jME libraries.  Then I tried the first tutorial:

package firstjmetest;

import com.jme.scene.shape.Box;
import com.jme.math.Vector3f;

public class Main extends SimpleGame
   public Main()
    * @param args the command line arguments
   public static void main(String[] args)
      Main app = new Main();
   }// end main(.)

   protected void simpleInitGame()
      Box b = new Box("myBox", new Vector3f(0,0,0), new Vector3f(1,1,1));
   }// end simpleInitGame()

Everything compiled fine.  I got the dialog w/ the monkey face asking what resolution I wanted to use. Chose the resolutio I had, clicked ok. A black screen window popped up w/ nothing in it, then disappeared.

Output indicates the following stack trace:

java.lang.IllegalStateException: Function is not supported
        at org.lwjgl.BufferChecks.checkFunctionAddress(
        at org.lwjgl.opengl.ARBBufferObject.glBindBufferARB(
        at com.jme.scene.state.lwjgl.records.RendererRecord.setBoundVBO(Unknown Source)
        at com.jme.renderer.lwjgl.LWJGLRenderer.predrawGeometry(Unknown Source)
        at com.jme.renderer.lwjgl.LWJGLRenderer.draw(Unknown Source)
        at com.jme.scene.batch.TriangleBatch.draw(Unknown Source)
        at com.jme.scene.TriMesh.draw(Unknown Source)
        at com.jme.scene.Spatial.onDraw(Unknown Source)
        at com.jme.scene.Node.draw(Unknown Source)
        at com.jme.scene.Spatial.onDraw(Unknown Source)
        at com.jme.renderer.lwjgl.LWJGLRenderer.draw(Unknown Source)
        at Source)
        at Source)
        at firstjmetest.Main.main(

What am I doing wrong?

I've got java 1.5 sdk and am running Windows XP

Looks like your card does not support VBO and some changes I recently added are not taking that into consideration.  I'll fix that up here soon.

Please update from cvs, this should be fixed up.

Yey! You fixed it!  Thank you. :slight_smile: