Imported Blender Animations jump between keyframes

Hello guys,

I have some problems with animations I import from blender.

I work with JME for about six months now and NORMALLY animations work like they should. But sometimes (about 1/5 of all animations) the animations “jump” at the first or the last keyframe. For example today I animated two arms going slowly up and down. This works like it should except the first keyframe: For any reason I don’t know the arms rise up high in the sky, what is neither the rest position nor a position in any other animations. Since it is only one keyframe I have to play the animation super slow to see what exactly happens, in normal speed you just see the high arms for short time.
Also I have some problems with the speed, what might have the same reason: Sometimes animations play like they should but much much too fast. When I slow them don in the SDK this is not saved.

Both of this occur in my application and in the SDK-preview field, so I guess they are not imported correctly. I do always apply LocRotScal in Blender and do everythin like the tutorials say. I tried to ignore that problem and just renewed and reimported every animation until they worked (if I changed anything in blender they often did, just exporting and importing without changes does not help), but it really annoys me.

Thank you for reading my long and hopefully not too hard understandably written text (I am no native speaker), and I hope you have any ideas to help me.

Kind regards,

I already had this.
Usually it an issue with the animations layering in the NLA editor.

Animations should never be on the same track.
Sometimes you have to let 1 frame between 2 animations…sometime they need to stick together.
Maybe try to play with that

Yes, I had the same feeling. Most of the animations worked after I put them all close together with no empty frame between. Just one did not. They should not be on the same track? The tutorial I watched before I started animations said they always had to be, maybe I will try it that way, thank you :slight_smile:

Yeah I think I must have followed the same tutorial, I was also told them must all be on the same track. I had this problem, but found switching to an older version of JME solved it : /

Though I thought at the time it was an animation blending problem

See this post from @wezrule there is a shot of what it should look like.
Note that as said before sometimes it’w wonky when you leave this 1 frame gap between animations.

1 Like