[Installation] [Error] wizard.xml.0:43:10: cvc-complex-type.2.4.b:

i got this:

[Error] wizard.xml.0:43:10: cvc-complex-type.2.4.b: The content of element ‘wizard’ is not complete. Expected one of ‘{component}’.

also a lot of this:

(java: 4524): Gtk-WARNING **: Unable to locate the tool in module_path themes: “pixmap”,

any ideia?

OS: ElementaryOS

JDK: JDK 1.7

Plz, ignore this post. I found my fault. I dont know how to delete this post… I think i am a =D . sry.

Could you share the solution?
I am trying to get a dev environment set up on a new Ubuntu 13.10 laptop. I have the Oracle 7u45 JDK installed (and eclipse). But when I tried installing jME 3.0 I got the same error. The wizard never asked for a project directory.

Now when I try to install it I just get that same error and get dumped back to terminal:

I have jME installed fine under Win8 on my work laptop, but I’d really like to get it working on the dedicated laptop.

Suggestions? Direction? Commandments & chiding?

I think it is not a error exactly. In my case, I forgot to do sudo ./jmonkeyplatform-linux-x64.sh, and i wasn’t finding where i installed, then i discorvered it was in /home/myname/jmoney… So i uninstalled it and installed again with sudo. It installed in /usr/local/jmoneyplataform.

you said:

The wizard never asked for a project directory
jmonkey install wizard or jmonkey IDE?

did you install JDK? which one: 8, 7, 6…? if its 8 you have to fix a parameter in jMonkey IDE because JDK 8 lack a parameter…

jME install wizard. I have not yet gotten jME IDE to run, though I now know where it installed (thanks :slight_smile:

I installed the Oracle 7u45 JDK and added it to path, but it looks like the install wizard is still trying to use the bundled JDK (which I’m ok with, if it works :stuck_out_tongue: ).

Uninstalled using the uninstall.sh in local.

Reinstalled with wizard. Wizard still generating the “not complete” error, but completes.

jME now available in App menu, but no icons on the desktop and running the IDE has no result.

Gfx card is Radeon HD 7310m with the latest Catalyst drivers from AMD.

I’m stumped :stuck_out_tongue:

plz go to where jme3 its installed and then type sudo ./jmonkeyplatform (terminal) then if any error happen paste it here…

if I drill all the way down to usr/local/jmonkeyplatform/bin and run
Sudo ./jmonkeyplatform
the IDE starts.

Terminal output while setting the projects folder was
MEvent. Case!
MEvent. Case!
MEvent. Case!

I’m now updating the plugins.

So, jmonkeyplatform/bin needs to be added to PATH?

just confirming, did it work? right?

Now answering your question: No. It needs to be sudo to work…

go to: /usr/share/applications/ then alter or create a file named jmonkeyplataform.desktop then type this:

[Desktop Entry]
Name=jMonkeyEngine SDK
Comment=jMonkeyEngine SDK A Java Game Engine
Exec=gksudo -k -u root /usr/local/jmonkeyplatform/bin/jmonkeyplatform

Now it will ask for sudo all time you start jmonkey from menu…

It did work. Modules have updated.

jmonkeyplatform.desktop did exist. Only change was to the “Exec” line. Modified it and rebooted.

There is still no icon on the desktop (the image does exist and the .desktop file does point to the image and the bin). and clicking on the menu item still appears to do nothing.

If I sudo ./jmonkeyplatform from the bin directory I get
Cannot find java. Please use the --jdkhome switch.

If I sudo ./jmonkeyplatform --jdkhome usr/local/jmonkeyplatform/jdk
I get the same message.

Thank you very much for helping me :slight_smile: I need to do some other things, so I won’t get back to this until tonight. Don’t want you to think I’m ignoring you. :stuck_out_tongue:

ok… i got something similar error once… but i dont remember what i did… later so…

Ok, new problem.
Wiped that install (I mean I reinstalled Ubuntu 13.10 on a clean HD, with updates and the latest Catalyst driver).
installed the oracle JDK + Netbeans (which looks like it uses the same installer as jME). Not a single hitch.
Put the jmonkeyplatform-linux-x86.sh in Downloads and ran it the same way (“sudo sh”).
Term is stuck before the “Configuring the installer…” stage. There is a bit of CPU activity (one core, about 80%) and a very repetitive disk access (reading only). This goes on until broken out of.
(Edit: jME installer acts the same whether I try it before or after installing the JDK+NB).

I’m really at my wit’s end. Installing jME shouldn’t be this difficult.

Update: After about 10-15 minutes the installer exits with
“jmonkeyplatform-linux-x64.sh: 211: jmonkeyplatform-linux-x64.sh: Syntax error: end of file unexpected (expecting “;;”)”

Corrupt download? Re-DLing…

did you this error installing jME or netbeans?

I only get that error with jME.
Downloading a fresh file now.

Netbeans installs without problems, every time. But I just can’t get jME installed and working on linux. Very frustrated.

Works fine on my work computer (win 8), but I can’t use it on my work computer… hence my dedicated monkey laptop that is being such a pain :frowning:

so did it finish installing or stop before installing?

It broke before “Configuring installer…”
Didn’t even get started, really.

Looks like I have another hour on this download (public wifi :stuck_out_tongue: ) Then I’ll try with a fresh installer.

any error message?
did you try to install jdk using:

sudo apt-get purge openjdk*
sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update

then 8:
sudo apt-get install oracle-java8-installer
sudo apt-get install oracle-java7-installer
sudo apt-get install oracle-java6-installer


Ok, the fresh install file worked, and I reinstalled the JDK your way…

This got me back to where we started at the top (that odd "[Error] wizard.xml.0:43:10: cvc-complex-type.2.4.b: " error), but the install completed.
Had to cd into the jmonkeyplatform/bin folder and sudo ./jmonkeyplatform --jdkhome {path/to/jdk} to get it to run (no icons created, would not run from dash/menu).

jME found and downloaded 35 updates (setting perms properly) and was able to load, build and run BasicGame with no problems.

It remains a CLI launch only app, however, where netbeans & eclipse seem to work fine from icon/menu/dash.

Anyway, I’m working (-ish) :slight_smile:

Thank you for your help! :slight_smile:

hahaha, not for that…

search for a working .desktop config for jME in ubuntu 13.10

Looks like all I had to do for the icon was install gksu (for the root-password pop-up) and copy the .desktop file to the desktop. :stuck_out_tongue:

I’ll get the hang of this. Honest :slight_smile: