Intellij Integration

Yeah I agree. This is just the start.

I’ll add that as an option.

That’s probably because you need to zoom out or move up. It might be a very large model, maybe?

My next step is to provide scene editing.

I’m glad you didn’t report any crashes or issues. That’s my main priority. Getting the engine to work from within intelliJ was a large task. Now that’s done and (to me at least) appears to be fine, I can progress implement more functionality.

Thanks for the review :heart:

1 Like

It was a model of a Valve Knuckles controller which showed up just fine when I imported the gltf file or even the same j3o file directly in code. Zooming in/out or moving about didn’t help.

This plugin has just been updated to v1.0.1 and is now available on the intellij marketplace, which means you can install it directly from within intellij and it will automatically update when they are pushed.

To install the plugin, from within intellij IDEA:

File -> Settings -> Plugins -> Search “JmonkeyEngine Integration”.


I was wondering, since you are adding support for Gradle, would it also be possible to get Maven support. I have never written plugins for IDEA, and have no idea what the environment looks like… :wink:

PS: Thank you for your continued work within the community!

1 Like

I feel personally that gradle is the way forward. The jmonkey store only provides gradle links, and in future will also provide the ability to “one-click” software from the store into your IntelliJ project, both as a dependency and a sub-module if it provides sources and you want them. That’s going to mean modifying the build scripts, and supporting multiple build types will mean supporting it along the chain (the store) too. In an ideal world I would, but as a one-man team it would take more than twice as long to get every step done.


@jayfella quick question for you.

Because Android Studio is based on Intellij, does that mean that this plugin will work with it?
Is that the basis for getting jme android support with Intellij?

PS: When you have a solid inplementation in gradle, I will work on a maven PR for it.

To be honest I havent actually tried. It might. I would like to be able to provide support for it but right now it’s untested completely. It would be nice to have a “new game” template for android studio.

1 Like

Yes please. I would also be very much interested.

Just tried out the plugin. When I attempted to open a j3o file I got this exception:

java.lang.IllegalArgumentException: Given root path "D:\dev\workspace\avt\src\main\resources" is not a directory
	at com.jme3.asset.plugins.FileLocator.setRootPath(
	at com.jme3.asset.ImplHandler$ImplThreadLocal.initialValue(
	at java.base/java.lang.ThreadLocal.setInitialValue(
	at java.base/java.lang.ThreadLocal.get(
	at com.jme3.asset.ImplHandler.tryLocate(
	at com.jme3.asset.DesktopAssetManager.loadAsset(
	at com.jme3.asset.DesktopAssetManager.loadModel(
	at com.jme3.asset.DesktopAssetManager.loadModel(
	at com.jmonkeystore.ide.jme.impl.JmeEngineServiceImpl.loadExternalModel(
	at com.jmonkeystore.ide.jme.impl.JmeEngineServiceImpl.loadExternalModel(
	at com.jmonkeystore.ide.editor.ui.JmeModelEditorUI.<init>(
	at com.jmonkeystore.ide.editor.impl.JmeModelEditorImpl.<init>(
	at com.jmonkeystore.ide.editor.impl.JmeModelFileEditorImpl.<init>(
	at com.jmonkeystore.ide.editor.JmeModelEditorProvider.createEditor(
	at com.intellij.openapi.fileEditor.impl.FileEditorManagerImpl.openFileImpl4Edt(
	at com.intellij.openapi.fileEditor.impl.FileEditorManagerImpl.lambda$openFileImpl4$7(
	at com.intellij.openapi.application.impl.ApplicationImpl.invokeAndWait(
	at com.intellij.openapi.application.impl.ApplicationImpl.invokeAndWait(
	at com.intellij.openapi.fileEditor.impl.FileEditorManagerImpl.openFileImpl4(
	at com.intellij.openapi.fileEditor.impl.FileEditorManagerImpl.openFileImpl3(
	at com.intellij.openapi.fileEditor.impl.FileEditorManagerImpl.lambda$openFileImpl2$4(
	at com.intellij.openapi.command.impl.CoreCommandProcessor.executeCommand(
	at com.intellij.openapi.command.impl.CoreCommandProcessor.executeCommand(
	at com.intellij.openapi.command.impl.CoreCommandProcessor.executeCommand(
	at com.intellij.openapi.command.impl.CoreCommandProcessor.executeCommand(
	at com.intellij.openapi.fileEditor.impl.FileEditorManagerImpl.openFileImpl2(
	at com.intellij.openapi.fileEditor.impl.FileEditorManagerImpl.openFileWithProviders(
	at com.intellij.openapi.fileEditor.impl.text.FileDropHandler.openFiles(
	at com.intellij.openapi.fileEditor.impl.text.FileDropHandler.handleDrop(
	at com.intellij.openapi.editor.EditorDropHandler.handleDrop(
	at com.intellij.openapi.editor.impl.EditorImpl.handleDrop(
	at com.intellij.openapi.editor.impl.EditorImpl$MyTransferHandler.importData(
	at java.desktop/javax.swing.TransferHandler$DropHandler.drop(
	at java.desktop/java.awt.dnd.DropTarget.drop(
	at java.desktop/javax.swing.TransferHandler$SwingDropTarget.drop(
	at java.desktop/sun.awt.dnd.SunDropTargetContextPeer.processDropMessage(
	at java.desktop/sun.awt.dnd.SunDropTargetContextPeer$EventDispatcher.dispatchDropEvent(
	at java.desktop/sun.awt.dnd.SunDropTargetContextPeer$EventDispatcher.dispatchEvent(
	at java.desktop/sun.awt.dnd.SunDropTargetEvent.dispatch(
	at java.desktop/java.awt.Component.dispatchEventImpl(
	at java.desktop/java.awt.Container.dispatchEventImpl(
	at java.desktop/java.awt.Component.dispatchEvent(
	at java.desktop/java.awt.LightweightDispatcher.retargetMouseEvent(
	at java.desktop/java.awt.LightweightDispatcher.processDropTargetEvent(
	at java.desktop/java.awt.LightweightDispatcher.dispatchEvent(
	at java.desktop/java.awt.Container.dispatchEventImpl(
	at java.desktop/java.awt.Window.dispatchEventImpl(
	at java.desktop/java.awt.Component.dispatchEvent(
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(
	at java.desktop/java.awt.EventQueue$
	at java.desktop/java.awt.EventQueue$
	at java.base/ Method)
	at java.base/$JavaSecurityAccessImpl.doIntersectionPrivilege(
	at java.base/$JavaSecurityAccessImpl.doIntersectionPrivilege(
	at java.desktop/java.awt.EventQueue$
	at java.desktop/java.awt.EventQueue$
	at java.base/ Method)
	at java.base/$JavaSecurityAccessImpl.doIntersectionPrivilege(
	at java.desktop/java.awt.EventQueue.dispatchEvent(
	at com.intellij.ide.IdeEventQueue.defaultDispatchEvent(
	at com.intellij.ide.IdeEventQueue._dispatchEvent(
	at com.intellij.ide.IdeEventQueue.lambda$dispatchEvent$8(
	at com.intellij.openapi.progress.impl.CoreProgressManager.computePrioritized(
	at com.intellij.ide.IdeEventQueue.dispatchEvent(
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(
	at java.desktop/

Not sure what’s going on since the directory “resources” clearly exists in my workspace.

would you mind PMing me the model?

model? but he have some dir issue. :slight_smile:

I’ve tried with several different models, including the boat from jme3-testdata. I feel like this could be a permissions issue. Although I’ve never had problems with other intelliJ plugins. Perhaps other plugins open files differently?

So you are opening files from a jar?

Because it may be an issue relating to loading textures and such required by the model.

All files are being loaded from a directory. Namely “src/main/resources/models/”.

Yeah. It might be a permission thing. I don’t check for permissions but I probably should. It doesn’t appear to have read access.

I’ve added some checks and dialogs for read and write where applicable. I also noticed a potential issue related to the path of the model. I’ll push an update in the next few days. I’m also in the middle of adding context menus to the scene explorer to add lights and such, so I’ll have to finish that first.

It does also take 2 days for intellij to validate it, so I’ll try to be quick.

Thank you for the report.

I’ve pushed v1.0.2 to intellij. You should recieve an automatic update once it has been validated. I’m confident it should fix your issue, @Mr_Marbles .

1 Like

… OK . Sounds good… but why I cant see the plugin in the Settings ? :see_no_evil:

Click “File -> Settings -> Plugins”.

Make sure you have selected “Marketplace” and not “Installed” at the top. Search “jmonkey” and it should be there.