Is this normal in: jmeTest/Terrain/

Hello all,

When I load I get an odd strip of terrain seemingly at the end of the fog and the beginning of the background colour. I’ve got a screenshot that should help identify what I’m saying:

I’m basically wondering if this is a problem with my graphics card (or drivers) or it is something that happens for everyone with and if anyone has any ideas how I can fix it?

I’ve tried the latest drivers for my card and also tried extending the distance of the fog, neither produced different results.

Hmm, have not seen something like that.  Do you see any odd results without the fog? (like flickering or something like that)

I have never seen this either, but I have experienced some weird behavior with dynamic level of detail… are you using such?

Thanks for your quick replies.

If I turn fog off, I don’t get the same ‘outline of terrain’ as shown in the first picture but I have noticed that the rendering seems to be cut short very early.

Here’s a series of screenshots, each a couple of degrees right. As I do so, the background colour seems to be rendered instead of the valley. In the picture there is a light patch of terrain that disappears as the terrain doesn’t get rendered.

I’m using a laptop with a pretty poor graphics card, I guess this could account for it if you both are not having this problem. The card is an onboard ATI Radeon Xpress 1100, but it can render this sort of data on XNA or OGRE so I’m unsure.

I haven’t started playing with dynamic LOD yet, but I will soon  :slight_smile: this is just using the test class bundled with jME.

The view distance is limited by the far plane which is set to 1000 units in this example.

cam.setFrustum(1.0f, 1000.0f, -0.55f, 0.55f, 0.4125f, -0.4125f);

view frustum

Thanks Core-Dump, it didn't occur to me to alter the view distance because the others said it was working fine for them. I altered the second parameter (the far value) up to 2000.0f and it works fine with or without fog. 1900f is the smallest value I can seem to get without getting this problem.