Issue importing .blend file

Hi everybody,
I’m a beginner with JMonkey and I tried to import a .blend with the “import” functionality. The mesh is imported but I have parts that are transparent and shouldn’t be transparent. In blender the rendering is fine so I was wondering why I have this transparency issue… Do you have any tip?

I don’t see anything wrong in the pictures you posted. :wink:


Where are the transparent parts? What is is supposed to look like?

Please help us help you by properly describing the problem.

not sure, but it looks like a normal issue to me.
make sure your normals are pointing outside.

You can see on the image that the eyes are strange, we see thru the face the globes and they aren’t hiden by the face. Here is how it should render :
Free Web Proxy

(forget the stick)

So the problems is we should only see the “visible” part of the eye and not the whole globes. Hope I’m enough precise this time…

so you just imported the model into JME?
You didn’t change anything on the material?

Yes, I didn’t changed anything I just imported it

could you try the ogre pipeline?

You don’t have depth write turned off on the material or anything like that do you?

I tried it but It don’t work…

My settings (don’t know if it’s correct):
Free Web Proxy
The error I get:

<cite>@zarch said:</cite> You don't have depth write turned off on the material or anything like that do you?

What is this and where would it be activated ? (the model is not mine)

I create my own materials but I think the import should have created one for you?

Have a look at the settings inside that…or try just creating your own material based off the standard lighting one and applying that to the geometry in the model to see if it makes any difference.

Do the eyes have any transparency?

To me it almost looks like the eyes are rendered a little in front because of Z-fighting but that they are partially transparent or something. Do the eyes show up as separate geometry in the SDK scene editor/explorer?

I finally got it working by remaking the whole material and reusing the textures like zarch said. So the problems is somwhere in the material but where… is another question :smiley:

Edit: I find out how to manage the mesh in the SDK thx Normen’s Tutorial. I could simply tell my mesh it has to be opaque and it worked. Thx to all of you!