Issue on IDE open w/ opengl viewer window(I think)


So I’m a little perplexed as to why I’m having this issue. When I launch the jMonkey IDE on my Windows 7 laptop, it opens up and then begins to happily spam warning windows at me nonstop until the program freezes. I was actually able to catch what the warning windows said once when it randomly decided to only pop up two.

Warnings say:

Error in scene!(for both errors)

java.lang.IllegalStateException: Framebuffer doesn’t have any renderbuffers attached.

org.lwjgl.opengl.OpenGLException: Invalid enum (1280)

Now, on my Desktop I have no issue, and as far as I have been able to check they are both set up the same, besides obvious hardware differences. I did install Linux on my laptop as dual boot and the jMonkey IDE launches there and runs with no errors.

I tried googling and searching this forum but did not find anyone that had this issue and had gotten an answer, but if I missed a topic that resolved this issue somewhere I apologize!

Thank you in advance for the help!

1 Like

A standard solution is to find the latest drivers for your graphics card, try that.

Sorry, I should have added that I did that already. It’s the intel integrated graphics though and the latest driver I found was a 2009 release on the intel website.

Have you checked your laptop graphics card and the version of OpenGL it supports etc?

I did check before I posted but I forgot to paste the information. Here is the openGL information I have for my system:

Video Card Vendor: Intel

Renderer: Intel 965/963 Graphics Media Accelerator

OpenGL Version: 2.0.0 - Build

GLU Version: Microsoft Corporation

Thanks for everyone’s help in advance!

Especially “heavyweight canvas” and “opengl1 mode”

Actually this issue might not be hardware related. I committed a fix to SVN just now that might help alleviate it.

I know this is an old topic, but I’m having exactly the same problem as nukesforbreakfast.
Is there a known solution?

My laptop’s specs:
Windows 7 (32 bit)
1.6 GHz Intel Pentium dual core
2 Gb RAM
Mobile Intel 965 Express.

Thanks in advance.


EDIT: I tried using “opengl 1 mode” and “heavyweight canvas”, but it still doesn’t work.

i have the same problem and i’ m looking for the solution for about a month

What Java version are you using?
I hear a recent upgrade to Java 6 broke the SDK (and a lot of other software that uses the same technological platform).
I also hear that it works with Java 7.

Note that that information is somewhat dated, but IF you are running the SDK with Java 6, this might be the cause.

I have this problem now with Java 7, but I had it also one year ago with Java 6 and Windows Vista (before formatting my pc’s hard disk).

Then it’s not the Java update.
Can you try downloading the SDK from the SVN repository and run it via “ant run”? (See )
It will take a while to compile everything, but you should see whether Momoko Fan’s fix helped.

I will try.

But I downloaded the SDK long after Momoko_Fan’s fix, so the fix should already be on my version of SDK.


It works! I compiled and run it and it opens without problems. Now I have to discover how to package the entire project inside a single executable jar with NetBeans.

Thank you very much!

Packaging would be “ant zip”, but that didn’t work for me.
I tried to ask for workarounds, but I never got a useful answer. Maybe it’s one of the reasons why nightlies aren’t being made right now; I just resigned to using “ant run” and let it do its little dance every time I wanted to start the SDK. It’s not that bad, just a minute or so on my machine - it’s smart enough to avoid recompiling all the Java files, though it’s not smart enough to avoid regenerating the unchanged Javadocs.

UPDATE: For reference, my attempt to get a solution ended on

<cite>@lodo95 said:</cite> package the entire project inside a single executable jar with NetBeans.
The use of fat JARs is neither smart nor safe. If the operating system uses another "porgram" than Java to open the JARs, it won't work and it is very often the case especially under Windows as lots of people install WinZIP and/or WinRAR. The problem is the same under Linux, the archiver often opens the JARs by default.

Actually, you don’t want users to open jars anyway, so where’s the problem?