Issues updating


I am trying to update to the latest build (SDK Nightly in Netbeans) but it isn’t downloading.

It just seems to hang on 2% of downloading plugins regardless of what update package I select.

I cant see any evidence of it beign a broadband issue on my end. Internet is fine. DL speed is fine and other netbeans components download and update fine. That said I am open minded to it being an issue on my end if anybody has any ideas for investigating further.

All the updates selected come to 57Mb which on my 8Mb connection should come down like a flash (like they normally do) so I thought I would check if there was anything up with the update servers?


1 Like

My last update some hours ago went fine.

Thanks for the reply.

Might be by JMP is borked then. I first tried to update this last night and had the same issue but it is definitly hanging at 2% and going no further.

Trouble is if I reinstall JMP from alpha4 base build I will have to update and if the update doesnt work I am kinda knackered!

Will try again in a bit and see what happens.




Tried again same issue.

Reinstalled from Alpha4 installer and can’t update any JMP packages at all - same issue (luckily I backed up my current JMP folder first so I can at least get back where I was.

Restarted system several times and same issue. All other internet behaviour checks out fine.

All other addons, updates etc are fine and this only seems to manifest with the nightly build updates so I don’t know what to do now.


I had a very similar problem this morning but did not have time to investigate why.

Hey Mattias,

When you get the chance let me know if it is still an issue because mine certainly is!

I have got back to where I was by restoring my copied folder but it is irritating for this not to update to the latest. Hopefully this problem - whatever it is - will be short lived.

I have diagnosed pretty much everything I can this end and the update from the nightly server seems to be the only thing affected. Not much I can do here now but keep trying and hope. I will leave it trying to update over night and see if that works but I don’t think it will unless something drastic springs back to life.


Yes, it’s still doing it - “Downloading plugins…”, hung at 0% for JMonkeyPlatform Core.

Internet connection is fine as I type this.

edit: The following file just hangs for me when I try to download it with a browser:

Filesystem or server problems?

Same problem here. Updating has been fine for me up to last night/today.

Reinstall is not a fix.


I tried updating last night and got stuck at 5% where it hung for an hour, at which point I gave up and went to bed. I’m trying to update right now as I write this post and I’m stuck at 0%. Please don’t dismiss this issue.


The build is done every night so when I got no idea on what to do and I cannot reproduce the issue I can just dismiss the issue until something else (like the faulty router last time) proves to be the problem. Most likely the issue will vanish with subsequent updates if its really in the range of the content of the actual updates.


Have you tried uninstalling jMP and updating from a fresh Alpha 4 copy?

On my Windows PC actually, yeah. Didn’t stop the time though, even in the worst times of router error I could still download, it was just slow, most people reporting “hangs” at certain percentage just didn’t wait for longer than 5 minutes.

No, have waited much longer than 5 minutes. In fact jMP decides its done waiting for the download on its own and stops the update process.

xD now which vodka was who? ^^

It’s color-coded for simplicity, but we have the same problem in this case so feel free to interchange for today.

Ok, just because you care so much for drunk germans and their means to discern vodka I triggered a build 3 hours before the regular build runs. I keep my fingers crossed for you (did you know that us germans “press our thumbs” instead?).

1 Like

Alright well I’ll press my thumbs hoping it works!

Thanks norm



I confirm the problem has been present for the last 24hrs. It’s still acting weird.

Updating modules individually helps but when it gets to jMP Core and jMP Test Data, traffic goes for a couple of secs to maybe 20 secs or so, then it abruptly stops. Sometimes it restarts but it’s rare. :confused: Since last revison of Test Data (yesterday) I haven’t been able to update that particular one.

Yeah, I asked @sbook to apply the fix that solved those problems last time… Guess that router is going haywire again, maybe it has to be replaced sometime…