.j3m material not showing up on geometry

I put the .j3m file in my assets/Materials/floor folder, it has all of the .png files inside. The .j3m looks like this:

Material FloorTexture : Common/MatDefs/Light/Lighting.j3md {

MaterialParameters {

Shininess: 5.0

DiffuseMap : Flip Materials/floor/floor.jpg

SpecularMap : Flip Materials/floor/floor_SPEC.png

NormalMap : Flip Materials/floor/floor_NRM.png



and the material file is loaded like this:

Material solid = assetManager.loadMaterial(“Materials/floor/floor.j3m”);

and then i setMaterial but it doesnt work.

Can you post the log?

if u use the beginner tutorial code this should work !!! i tried and it works fine.

maybe you forgot to call myModel.setMaterial();

do you have lights ? else the model wont show.

I have lighting, i set the model setmaterial. still doesnt work :confused:

Can you tell us more about “doesn’t work”? Does the app crash? Are there errors in the log? Does it run and just show nothing? Does it show your object all black?

Can you post some code that we might help figure out what the issue is?

What is the “geometry”? Something you’ve create using one of the standard meshes or loaded from a file?

Normally, this works just fine so we need some information to go on to help to figure out what specifically the issue is in your case.

Fixed it.

It would be nice if you post your fix to help other people out! Someone might run across the same problem.