j3o UV mapping good on JME, but not on android

I’m running my app with the following code which works fine on JME

Node player_geo = (Node)assetManager.loadModel(“Models/ghost3/ghost3.j3o”);
playerMaterial = new Material(assetManager, “Common/MatDefs/Light/Lighting.j3md”);
playerMaterial.setTexture(“DiffuseMap”, assetManager.loadTexture(“Models/ghost3/ghost3.png”));
player_geo.setMaterial(playerMaterial);

The ghost3.j3o is a converted from a .blend file, and the ghost3.png was made with blender UV mapping. It renders as intended in blender and this also renders well running in JME.

However, when I run it on my Galaxy S2 Android phone, the texture is no longer UV mapped correctly. Texture goes on the model, but not in the right way.

I imagine this would be solved if I could get the material on a j3m file or get everything into the j3o file, but I haven’t figured out how to do this yet.

Any idea why it renders differently on Android vs JME?

I’ve seen lots of these S2-troubles in the forum lately.
It seems that upgrading your phone to android 4.1 (I think) solves most of the issues.