Javafx gradle plugin

Hi there, a monkey takes a few months of vacation and on return, nothing works? This is my misadventure:

  1. attempted to build my game with javafx-gradle-plugin (it worked until March). Result: error with some libs.
  2. attempted to rebuld my lib: Result: won’t compile because dyn4j was updated with an incompatible API
  3. fix the code and point 2) is solved.
  4. New attempt to build the game. Error with gradle: there is a bug that looks like is solved with the latest version
  5. Update gradle (4.x to 6.x). Error: javafx-gradle-plugin has some error and is no longer updated.
  6. Switch to openjdk javafx gradle plugin. Error: won’t work with Java8. Update to Java14
  7. Error: not found!
  8. Added the module-info and finally:

(package com.jme3.scene is declared in module jme3.core, but module mygame
does not read it)

Any suggestion is welcome :sweat_smile:

Sounds like you had an upgrade cascade starting from some early errors that could have been fixed in a different way. So one options is to go back and use the earlier versions and get on with things. (Like number 2 seems strange that it would upgrade without your specifically doing so… something to be aware of about your setup in the future, I guess.)

Of course with your current path, when everything works you’ll be on the latest versions of things at least.