JME Alpha 4.. weird experiences

Hey, I understand that the Alpha 4 was just recently released. Just wondering if anybody else is having the following issue.

in the IDE itself, several interfaces turns all black where you can’t see anything but the dialog title bar. When using the Intellisense tool, and scrolling through the listed options such as the methods, etc, seems to reproduce the issue, and while going through the dialogs to update JME seems to also reproduce this effect. I hope this was clear enough to understand what I mean.

I’m running Windows 7 Home 64 bit.

Edit: The JME is updated to the current nightly build.

You mean when other windows open? Is it actually when you are scrolling in the update center or when you open the updates window? Also, does it just flicker or does it stay black? If it stays black, can you still “use” the UI by clicking on it etc? Do the windows partially reappear when that is the case?

I can still use the UI by clicking and arrow/tab keys, etc.

It does sometimes flicker as I use the UI… It does do it while scrolling through different elements.

It doesn’t seem to do it or do it often while using the code editor but other UI dialogs does affect the dialog itself and other dialogs including the main IDE window and the code editor.

Sometimes the UI is partially black, such as black background, but I still see the buttons. I’ll post some screenshots.

Some screenshots:

Try updating your JDK

Seems to be updated to the latest build as there was no new updates.

I know my partner is not having this issue, and I do believe he is using the same OS version as me. Could be just my computer, though it wasn’t doing this before, I just wanted to see if others were having a similar issue. Either way, it’s pretty odd.

No, the Java Development Kit:

Oh my bad, read JDK as JME for some reason. I do have the latest JDK 6, which is version 24…

I’ll try to reinstall JME, I’ll post results in a few.

Fresh Install:

Issue still persists.

After updating to the latest build…

Problem still exists :frowning:

Could it be you have an older JDK installed somewhere and the SDK finds that? You can specify a path to the JDK in (Application Folder)/jmonkeyplatform/etc/jmonkeyplatform.conf

I did had some issues with my classpath and using an older version of java, which i fixed. But still didn’t solve this issue :confused:

I am new to jMonkeyPlatform and I am experiencing the same problem. Running on Windows 7 x64. All panels are flickering black. I already had the problem with the installer when I had to browse to my installation folder.

I installed the following java applications:

  • Java update 24
  • Java update 24 (64-bit)
  • Java SE JDK update 24(64-bit)

    I have never installed any other JDK on this new PC.

    I also asked a question on superuser.

    Do I need to install JDK 32-bit as well?

As for now, it seems that installing JDK 32-bit solved the flickering. Still testing on it, just to be certain.

Too bad, the problem returned very quickly. I have this problem with other Java applications as well. Is there no one who had this problem and fixed it?

Generally seems to happen with bad graphics card drivers. So first I recommend updating them, if that doesn’t help, you might have to pass a few flags to jMP to disable hardware accelerated GUI.

Same Issue here

on Windows 7 64 bit too with JDK 64 Bit and JRE 32 and 64 bit

Even got this with other Java Applications and it usually kills my Display driver, which is restarted by Windows…

At my guess it’s something with the JRE/JDK and Windows 7 64…

If other Java applications fail then its definitely your graphics card driver.

They dont fail, other applications just show black screens sometimes. Even if its black, the applications react, meaning, if you know where the button is you can click it and it is visible afterwards. Sometimes scrolling helps making screens visible.

Will update the graphics card driver, but i think it is up to date.

But you said the applications cause the display driver to crash and then restart? That issue no longer occurs?

Yep, JMonkey SDK does that, other applications show mentioned black screens.

Just for the record, what graphics card is this?

I’m new to this discussion, but thought I’d add my two cents.

I have an ATI HD 4850. I haven’t run any other java apps recently, so I’m not sure if this is effecting those as well, but it is making working in jmp literally impossible.

I’m also seeing black screens/areas appear, especially when navigating the menus. I also have the latest versions of Java 6 (32 and 64 bit), as well as the latest catalyst drivers (11.8, currently).