Jme Animations Messed Up

So I have tried to import a blender 3d model with an animation into jme and when I play the animations, the gun slide moves the wrong way and the fingers on my arms are all glitched out. How do I fix this, JME doesn’t play my animations like when I play it in blender

before exporting to jme apply the bone and model’s location, rotation and scale with Ctrl+A

1 Like

I’m sorry, don’t know what you mean by apply the bone and model’s location

first, select your bone and model that has animation
next, use Ctrl+A and select rotation, location and scale

select rotation and location and scale?

Also, be sure that rotations are expressed with quaternions and not mixed with euler angles in the same animation, this gave me problems a while ago, but with the old loader, so i am not sure if this is still an issue.

EDIT: i am talking about this

how do you do that? Sorry for being a noob.

But first do what AF suggested

how did you do make sure it is a quaternion rotation though?

See the second screenshot, the dope sheet tell you which kind of rotation it is, in the screenshot the first bone uses quaternion rotations while the second one uses euler rotations, you should have only one type.

The format used in the animation depends on the one you set for each bone on the properties panel (the one you open with N), if you have bones with mixed euler and quaternion rotations, in the same armature, you should change the format of each bone in order that every bone has the same type of rotation, a quick way to do this is selecting them all and execute this script

import bpy

pose_bones = bpy.context.selected_pose_bones

for n in pose_bones:
    n.rotation_mode = 'QUATERNION'

And then you have to redo the animation, i don’t know if there is a way to fix already made animations

I tried to apply location and rotation the model doesn’t move now…

can you post the blend?

Ok Wait

I’m not seeing any problem aside the fact that the model was upside down and that the scale in ‘Reload’ animation is wrong.

I tried applying the scale, the animations still coming out weird when I import it to jme:
this is with another model::

In Blender
Slide Moves back when pistol fires.

Entire Model Moves to the left

How do you import that movie into the forums

Are you importing the .blend directly or did you export it in the ogre format?

If you post a link that ends with a video extension (eg. .mp4) the forum automatically embed it as an html video, if the link is direct but has no extension(like google drive ones) just add #.mp4 at the end,like that:

Im importing it straight into jme as a blend file.

Do I have to do anything with the NLA Strips?

Well, if the animation isn’t too complex i would suggest you to try to apply all transformation before and redo the animation.
Probably something has been changed in the blender loader shipped with jme3.1 because as you see in the video the animations load fine on my installation.