jME crashes JVM in Mac OS X 10.4.8

I recently loaded up my game in Mac OS X 10.4.8, with a big OpenGL update in the latest OS X update. I have a terrainpage in a JMECanvas. Everything goes fine until I zoom in far enough that I allow the model (.jme models) to appear. Once this occurs the system crashes with the following message:



Invalid memory access of location 6143a080 eip=940ca5b4



No stacktrace.



Any idea in  which direction to look. I'm guessing it has something to do with the opengl update, but I'm not sure.



Thanks.

The problem has been solved, with massive help from Mojo.



Since the update OS X's OpenGL doesn't like it you misbehave and have textures that are not equal to the regular sizes. After all the testure were resized, things work again.

I recently bought a new MacBook Pro - Intel Core 2 Duo - and get the same error when trying to run the TestJMEDesktop demo.


Invalid memory accesss of location 000001f4 eip=1b3dd744


After playing with it if I comment out line 133:

jmeDesktop.setLightCombineMode(LightState.OFF);



it will actually run, but at 4fps.

I don't have any trouble with the demo on my pc or old (non-intel) mac.

I've run a couple of other demos and don't see any problems (shadow demo, water demo, model loading).

If only I could get myself a nice Macbook Pro… if only…