jME demos not working via JWS

The jME demos appear to be hit and miss. Right now I can’t get any of them to work via JWS. This is on my home computer and the work one.



The home laptop is a winXP, ATI setup. The work desktop is a winXP, GeForce setup.



Are others having any issues?



What’s the most appropriate place to post/ask for help?



They used to work BTW.



I can’t get the latest .9x version of lwjgl to run either.



Regards,

Dr. A>

If the latest LWJGL doesn’t work, jME won’t work for you either. It sounds like either cards that are too old or video driver issues. What are your exact cards and have you tried upgrading the drivers?

Here is some info from running glView.



NVIDIA Corporation

1.5.0

GeForce4 MX 440 with AGP8X/AGP/SSE2

GL_ARB_imaging GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shader_objects

GL_ARB_shading_language_100 GL_ARB_texture_compression GL_ARB_texture_cube_map

GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat

GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader

GL_ARB_window_pos GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color

GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_draw_range_elements

GL_EXT_fog_coord GL_EXT_multi_draw_arrays

GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_rescale_normal

GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shared_texture_palette GL_EXT_stencil_wrap

GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex_array GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_fence GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_register_combiners GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_NV_vertex_array_range

GL_NV_vertex_array_range2 GL_NV_vertex_program GL_NV_vertex_program1_1 GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_lod GL_SUN_slice_accum GL_WIN_swap_hint WGL_EXT_swap_control WGL_ARB_buffer_region WGL_ARB_extensions_string WGL_ARB_pbuffer WGL_ARB_pixel_format WGL_ARB_render_texture WGL_EXT_extensions_string WGL_EXT_swap_control WGL_NV_render_texture_rectangle WGL_ARB_make_current_read



Max Lights 8

Num Clip Planes 6

Max Model View Stack Depth 32

Max Projection Stack Depth 4

Max Texture Stack Depth 10

Sub Pixel Bits 4

Max Texture Size 2048 x 2048

Pixel Map Table 65536

Max Name Stack Depth 128

Max List Nesting 64

Max Eval Order 8

Max Viewport Size 4096 x 4096

Max Attrib Stack Depth 16

Point Size Range [1.000, 63.375] Granularity 0.125000

Line Size Range [0.500, 10.000] Granularity 0.125000

Max texture units 2



Given the fact I can run lots of other openGL apps, I'm pretty sure something else is going on. The drivers should be at most a few months old. I can understand trying to do something such as using a vertex shader would fail, but just a simple cube demo app, should be fine.

There isn't any kind of clean exit from lwjgl either, just exits. At least jME says something was wrong, then exits.

Should I try messing with the lwjgl code first? I've got no experience in jni, so I could only look at the java code itself.

Regards,
Dr. A>

The demos used to works on my cpu unless I switch to lwjgl 0.93… (this version of lwjgl works very well, I use it every days)



Chman

I think the last officially supportet LWJGL Version for jME was 0.92 - does it work with 0.92 ?

Right, webstart version is LWJGL 0.92, make sure you don’t have 0.93 in your system path or something. It could be interfereing with webstart pulling down 0.92 and setting it as the active one.

OT: lwjgl .93 is officially out now so we could work on supporting that… It would fix some issues we currently have such as how opengl pauses if it loses focus and the whole windowed mode being in the upper left corner instead of centered.

The lwjgl site only shows .93 alpha. Do you have to get the sources to get .93?



Any ideas on why my card is acting goofy? I tried some jogl demos today and got them working with no issues.



Regards,

Dr. A>

LWJGL 0.93 is out… Don’t read the “alpha” things, it just means that lwjgl is in alpha status (until 1.0 is out).



Chman

I was sorrta able to get the demos to work, but not by using the JWS versions.



I pulled the source from CVS and did a build. The first few demos under the jme.renderer package seemed ok.



When I tried the water simulation under effects, it put the text on the button, but that was it. Then when I hit ESC on the windowsXP laptop I was using, it blue screened then rebooted!!



AHHHHHHH!!!



Has this happened to anyone else? I ‘think’ I recall having a blue screen before when I tried to used one of the JWS demos.



Dr. A>