JME, Eclipse on Mac OS X 10.3.9

Hello, could someone walk me through building jME? I have Eclipse installed and have created a new project via the "from cvs" option. jME has downloaded from cvs and I think I did an ANT build with the result…

Buildfile: /Users/doconnel/Documents/dev/eclipse/workspace/jme/build.xml
[mkdir] Created dir: /Users/doconnel/Documents/dev/eclipse/workspace/jme/build
[mkdir] Created dir: /Users/doconnel/Documents/dev/eclipse/workspace/jme/build/com
[copy] Copying 3 files to /Users/doconnel/Documents/dev/eclipse/workspace/jme/build/com
[copy] Copied 71 empty directories to 48 empty directories under /Users/doconnel/Documents/dev/eclipse/workspace/jme/build/com
[javac] Compiling 402 source files to /Users/doconnel/Documents/dev/eclipse/workspace/jme/build
Total time: 29 seconds

This is a correct result…

You should have compiled classes in the build directory. If you want to build the jars, run ant with the dist-all target.

The tests are in jmetest and controlled with the buildtest.xml file.

ok! Got the all the jars built using the terminal and info from "Getting Started". Is it possible to do this directly from Eclipse?

Next I tried the tests using the following alias…

alias jmetest="java -Djava.library.path=./lib -cp ./lib/lwjgl.jar:./lib/jogg-0.0.5.jar:./lib/jorbis-0.0.12.jar:./target/jme.jar:./target/jmetest.jar:./target/jmetest-data.jar:./target/jme-effects.jar:./data"

Most worked and I'll provide a more detailed report if needed. I know that the Mac Java expects extras in specific directories, eg, "~/Library/Java/Extensions", and won't search sub-directories in those. This explains the very long classpath above. Is there a better way? I suspect the ones that failed mostly did so because they could not find data but the classpath would get extremely long if I included all the "data" subdirectories! There has got to be a better way?

Anyway, I appreciate anymore help you can provide. Here are some of the errors I'm getting...


May 15, 2005 12:25:07 AM com.jme.input.lwjgl.LWJGLMouseInput setCursorVisible
WARNING: Problem showing mouse cursor.
java.lang.NoClassDefFoundError: com/jmex/model/XMLparser/Converters/MilkToJme
        at jmetest.effects.TestDynamicSmoker.simpleInitGame(Unknown Source)
        at Source)
        at Source)
        at jmetest.effects.TestDynamicSmoker.main(Unknown Source)

jmetest.effects.TestParticleSystem: Runs but with white strip at bottom of window. Also reports "Could not load image... URL was null.". jmetest.effects.cloth.TestCloth works and shows texture but report same error.

jmetest.renderer.TestSkybox: works ok, shows texture but reports same error and "java[1222] _initWithWindowNumber: error creating graphics ctxt object for ctxt:44543, window:6299"


java.lang.NoClassDefFoundError: com/jmex/model/XMLparser/Converters/MilkToJme
        at jmetest.renderer.loader.TestFireMilk.simpleInitGame(Unknown Source)
        at Source)
        at Source)
        at jmetest.renderer.loader.TestFireMilk.main(Unknown Source)

Dude, just put all the compiled jars into ~/Library/Java/Extensions. Including lwjgl.jar, jme.jar, jmetest.jar, jmetest-data.jar and all the native libraries as well. Then simply type in the terminal ‘java jmetest.renderer.TestBoxColor’ or something like that.

Duh, hadn’t thought of that - thanks for reminding me :stuck_out_tongue:

Now most of the examples run ok. Widgets fail altogether and I don’t seem to have any fonts. Also keep getting following but it does not stop the program…

_initWithWindowNumber: error creating graphics ctxt object for ctxt:51539, window:7079

Is there a parameter to bypass the display settings dialog?

Thanks again for the help.

Try downloading lwjgl 0.96 from