JME Examples problems

Using Alpha 4, updated today, running on a Mac, java version “1.6.0_24”

I’m working with the provided examples to learn my way around. The example jme3test.model.shape.TestCylinder did not work properly for me - it just creates a circle. So I went to the API and looked up cylinder. All the constructors show a String field “name” as the first argument; when I tried to add this, the IDE flags an error saying ‘no suitable constructor’. I tried the same sort of thing with the jme3test.model.shape.TestBox, and got the same result.

It seems that the API doc I’m looking at ( is not in sync with what the IDE is using. (And the “FRAMES” version of the API docs generates a 404)

Which / how should I change to get them in sync?

Either use the javadoc that comes with the IDE (Help Menu) to get the javadoc for the alpha-4 version or update the SDK to latest nightly to get the latest API changes (and possibly other problems temporarily).

thanks - my docs match now. Can you confirm that TestCylinder does not work ? Also, if I attempt to Clean & Build the Jme3 Examples, TestTempVars fails to compile. Should I destroy the project and re-create to update?

Yes, recreate the project.

OK, the compile errors went away, but the TestCylinder still does not work - all I see is a white circle. I’ll test tomorrow on Linux, but that is the result I had there before.