Jme GUI does not show up

hi guys ,

I have 4 problems with Jme

I’m new to Jme , honestly i’m even new to gaming engines and linux in general , but i’m learning though :stuck_out_tongue:

i installed Jme on my ubuntu 11.04 , by changing the properties settings of the “.sh” file to " run as executable"

then the installer run fine and everything, yet when I click on the desktop icon , nothing happens … that’s the first problem .

so I followed some advice from an expert to uninstall it and re-install from terminal as a root user (using sudo command), and it did install , but with no shortcut icon on the desktop , so how would i run it ? that’s the second problem .

then i decided to re-install the “.sh” as executable file , and when i click on the desktop shortcut icon of Jme (after installation complete) it popups that error message: " an instance of the program cannot access the specified folder , make sure that home/xxx/.jmonkeyblatform/.03beta is writable". the problem is that folder i could’t find on my system . and that’s the third problem . after that i again uninstalled the ".sh file using the uninstall file in the Jme folder again.

then i noticed from the forum that it is a kind of error appears when trying to install the package with a different user rights . so when i try to un-install the “sudo installed” Jme , i didn’t know where exactly is it , then i tried to check if Jme is still “sudo installed” on the system , so I made another terminal installation try using “sudo” (just to check) . this time it popups the GUI wizard installation with only a single message in it that says: “Jme is already installed on your system”.

and that is the fourth problem .

how can I fix it and make Jme work on my 11.04 ubuntu ?

any kind of help is really appriciated


First, Make sure you have the proper version of Java installed for jME and Linux, jDK6 is recommended I believe. Link here.

Follow the Instructions on the Oracle site for installing.

Open jDK isn’t what you want.

As for permissions you can check this link here

I’m currently back on a windows workstation, but have installed Java and jME on ubuntu before. Hope this will help.