jME Model Converter GUI

… the one hosted on the site didn’t work for me, so I made a very simple GUI of my own. In case anyone is interested…

It has a drag and drop interface, and leaves a converted version along with the dragged in file (ms3d, ase, md2, md3, obj).

Download (zip, includes src and a batch file).

If someone feels like making a better distribution of it, e.g. webstart, that would be awsome!

Ok, i think i 've solved the problem of my converter.

when the new feature for the converter were made, i forgot to upload a new version on my site :// so if you use a recent jar of jme it was not OK.

I have uploaded a new version with a new jme.jar bundled with it (no need of lwjgl) and the command-line to launch it.

So, i hope it will work for everybody.

@Badmi : actually i’ve tested on directory out of the working directory without problem, this is strange…

If anybody is interested and has the time to test it…



Yep, I’ll get it up there soon. Some thing with work and class are causing me to have little free time right now, but I’m going to get that page down ASAP.

Mojo: if you think it fits and all that, I’d love to see it hosted at the Third Party Apps section :slight_smile:


  • Now converts XML files as well (so I now call it format converter :))
  • No LWJGL dependence - using DummyDisplaySystem
  • Executable jar file

    Download (src & jar ~ 40kb)

    Download (src, jar and jme v0.8 ~ 450kb)

    Enjoy 8)

I found that I needed to put the models in the working directory when using adenthar

Well, It starts up fine and says it’s ready and everything. Then I can choose input and output directories, but when I press the convert button nothing happens. No error dialog or anything. Same thing when I have the jme and lwjgl librarys in its working dir.



Is the converter you speak of the converter from magikopera ? (mine)

if so, can you explain me, the error you had with my converter GUI ?

perhaps i can correct the problem.



Great :slight_smile:

Oh, another thing: I’ve named it model converter insead of format converter, because at this point it doesn’t convert xml files - I’ve never had the need for it myself.

I’ll probably add this feature soon if noone beats me to it

Okey, I replaced jme.jar with the official 0.8 one, and made eclipse rebuild the project targetting 1.4…

Could you see if it works now?

Doh! I’m on it.

you need to recompile it for 1.4 :slight_smile:

Its currently under 1.5 (the jme.jar is under 1.5 too )


Not sure if this is linked elsewhere, but this is a must for any jME coders.

Make sure you get the last version from