Jme on a Netbook?

Could it be possible that jme would be unable to run on a Netbook due to graphics acceleration incapability?  The reason for my asking is the fact that every time I attempt to test jme,  I am thrown a severe exception.  org.lwjgl.LWJGLException: Pixel format not accelerated

that error usually means that OpenGL is missing, so LWJGL won't run. You could try run in software mode (using lwjgl hidden parameter) but its unlikely to give you good enough performance.

I've tried out Grappling Hook an a Mac Mini with an Intel GMA 950 chip, and it worked ok, without shader and low resolution of course. That does not mean, that I would recommend to play it on such a chip, but it is possible.

Works on samsung nc10

Which netbook are you using, Tocomomo?

If it has Intel chip then jME should work with recent drivers. That is, assuming the jme game/app doesn't use advanced features of course.

sbook said:

Which netbook are you using, Tocomomo?

I am using an Acer Aspire One 11.6 inch netbook.

I have decided to use my netbook as a client to my much more powerful desktop using realvnc, for this is how a netbook was original intended to be used.

Good question, how can we generally find out whether a certain machine will run jME? I don't really know what the exact criteria are… If the graphic card supports OpenGL, it runs jME, is that it?

Do I always have to option to fall back on the software mode (taking my chances that it will be very slow and very ugly, no shaders)? Do I always have to check whether Linux drivers exist and support OpenGL, ot is that pretty much standard…?

Let's assume the use case for the netbook is development only, not playing the game. I just want to make use of time  during a long train ride, and I will need to run it to see whether I didn't completely break my code. Should that work?

Netbooks usually have 1-2 GB RAM and an 1.6GHz Intel CPU – should be OK for small and medium sized games, right? As far as graphic cards are concerned, the Acer Inspire One seems to have "Intel GMA 500", Samsung has an "Intel GMA 950" (Empire Phoenix said that works), and an Eee PC seems to have a "Intel GMA 900". Has anyone ever tried jME on an Eee PC? How can I make certain it will work before I buy one?

On a related note, I've seen the error Tocomomo posted about when I set the JVM -Xmx parameter too high. In my case, I was setting it to 800m on a 2gb laptop. Anything higher and the JVM would start, but when the properties dialog closed and it tried to launch the game itself, I'd get the "pixel format not accelerated" error. I assume that this is because the native libraries need to allocate memory on the system that the JVM can't "see".

Is there a rule that governs how much memory the native side uses? Is there any way to detect this on a system and avoid allocating too much JVM memory and causing openGL to fail even if it IS supported?

Zathras, I've personally seen jME work on several different versions of the Intel GMA chip, and I know for sure the 965 runs (minus advance stuff like shaders). I can't speak specifically to Eee PC though. According to the hardware compatibility list ( it looks like all the 900s work without shaders.

Has anyone ever tried jME on an Eee PC?

I developed Exodus Defence partly on an eeePC  in a jeep :)
Just stuck eclipse and jME on it, no problem at all.
Alric said:

Has anyone ever tried jME on an Eee PC?

I developed Exodus Defence partly on an eeePC  in a jeep :)
Just stuck eclipse and jME on it, no problem at all.

...  That is TOO AWESOME!  Like am off-road code ninja!

As for the topic at hand, It really depends on the size/scale of the game.  The project I'm working on now is rendering entire cities and my 2006 MacBook Pro (2.16 GHz, x1600 256m, 2GB) has trouble handling it.
I developed Exodus Defence partly on an eeePC  in a jeep :)
Just stuck eclipse and jME on it, no problem at all.

Awesome, Eee PC, here I come!  :D


And by eee pc I mean... a netbook. I got my hands on an Intellibook with typical netbook specs and some weird big buttoned Linux recently. The owner let me run a Java sample app from a USB stick. It was just a jME SimpleGame with a teapot, spinning as fast as it can. (I did not quit other running applications.)

First I cheered, because it did run fine. Then I pressed F4 (?) and saw the framerate was in the single digits... :-o (What exactly does this F4 screen calculate?)

So technically it works, but anything more complex than a teapot will be slow. Since the graphic card has so little memory I hope you gain a few fps by quitting Firefox and everything? I'll be looking into a Dell inspriron mini next and will report back.         

I'm posting this from a Dell inspiron mini 10v with Ubuntu: Small to normal-sized jME applications run fine! Of course some shaders (?) are missing, for instance water doesn't look as impressive. But at least it still looks like water, the quality is degrading gracefully, it doesn't just crash or anything. I see a few more rendering errors (where two things meet they sometimes "fight"), but up to now that didn't break anything. My app doesn't have any special effects so I could test that yet.

Since the time of this thread and its resurrection, I put my hands on an Acer Aspire 1410…  11.6 inches, but it has the distinction of having a dual core celeron, so it's pretty snappy when compared to other netbooks i've played with.

Graphics are also a bit better than the standard GMA 950's, this has a 4500 MHD… it's definitely no 9400m though.

I get just under 20 FPS when running the TestProjectedWater jmetest

I went to my family over the christmas-days with nothing but a acer aspire one l110. :smiley:

Actually I didn't think that I  could code with it, but I have to say it is possible. So

I got some progress in my jME-project and I'm quite satisfied with the netbook. Ok,…the

3d performance is not the best, but who cares… Most of the features are working that is

what counts most for me…