jME-Physics Works Again!

Thanks be to Mojo for his willingness to hold my hand as I tried to figure out all these new changes in the system and helping me debug some of the code.  But it was all hopefully worth it as the code has been checked into CVS and jME-Physics should work again with jME.

Let me know if you have any problems with anything that worked before and you can point the finger at me, just be mindful of which finger it is. :-p


Great work!

It should also be added that the only "real" part that jME 0.9 had broken, was the org.odejava.GeomTrimesh. The other stuff were all just tests.

This is true…GeomTriMesh was a pain to fix too. :-p

Can somebody please find the time to troubleshoot my jME-physics install? I’m having troble getting any of the included tests to run. Here is what I get: TXT

I,m running the latest jdk, the latest jME compiled distribution (tested with included test demos) and the latest jME-physics. Any idea what this means?

I think this tutorial can help you, also if you use another ide than netBeans:

otello, simply recompile all the sources and make sure you are not having any jar with old classfiles of what you are compiling

all the errors seen in your output result from inconsistently compiled classes (except from the first: BallThrower is no application)

thanks, both of you! I am using netbeans, so that guide will come handy. I thought the .jars in the release are being kept up-to-date…apparently it isn't so.

so it's working finally, but not without a fight. this time, I did everything according to the instructions linked, but for some inexplicable reason, jme-physics insisted, it cannot find org/lwjgl/LWJGLException, even though the lwjgl.jar was listed first in the classpath and none of jME's own example demos had a problem with it.

extracting the jar solved the problem. I hate these moments.

That's what you get for using NetBeans. :wink:


darkfrog said:

That's what you get for using NetBeans. ;)


ha! you must be one of those Eclipse users, I gather.

but no, it seems it's my fault again. I had forgoten about one old forsaken lwjgl.jar in my JRE directory and the listing order on the classpath did its part.

One of those heathen Eclipse users…yes sir!  :slight_smile:

Yeah, I hate those rogue jars. :wink:


moral of the story, never stick libs in the jre directory.  Evil… evilllll!  :slight_smile:

Otello, you might want to hide, it looks like you've struck a vein in Renanse and he might come hunting for you trying to sacrifice you for the wrong you have done. :o



hi… is the physics engine not working with the current version of jme again?

I've been trying to compile but it keeps giving error message cannot find symbol

symbol  : constructor StaticPhysicsObject(com.jme.scene.Node)

location: class com.jmex.physics.StaticPhysicsObject

        StaticPhysicsObject map_p = new StaticPhysicsObject(mapNode);

and this bit confuses me as well syncWithGraphical(boolean) in com.jmex.physics.DynamicPhysicsObject cannot be applied to () tank_p.syncWithGraphical();

I'm trying to compile it with the jar files given. Tried to build the sources from cvs, but it's not right as well  :?

Can someone put up the current working jar files for the physics that works with jME please??

Currently, I have a working program running, but that is on eclipse, which I run on ubuntu. The thing is I'm trying to make it to be a standalone program and need to port  the programs to Windows as needed.

I'm guessing that eclipse keeps a working class files, which came from the build I did for some time ago,  somewhere, thus keeping the codes running.

I'll try to take a look into this tonight if no one else helps you before then.

I am currently running from the most recent version of jME and jME-Physics from CVS and am having no problems.  I believe that 0.9 jME should work with the most recent code from jME-Physics in CVS as well but I have not verified.


Yes, the jME phyiscs cvs version works fine with the current jme cvs version. The errors you have posted are located in another code part (in "cblast", whatever that is). Please check that code and use the new constructor of StaticPhysicsObject and remove the parameter from the syncWithGraphical call.