JME wont install

I am on Windows 7, and am trying to install JME 3. I have JRE 6.0_27, JDK 6.0_27, and the 32 bit version of both. it still wont install. I even reinstalled all versions of java, redownloaded the JMonkey installer, and still nothing. Help please!

What does “nothing” mean? If the installer doesn’t seem to start when you double-click it, run the installer from command line to see any error output.

In the installer it starts, waits about 3 seconds, then it says “Java SE Development Kit (JDK) as not found. JDK 6 is required for installing jMonkey platform…” I have probably every version available, and have checked my classpath and path, and it still says not found. I even tried just having the 64 bit version (JDK), and uninstalling every other version but it didn’t work.

Run the installer with the [xml]–javahome [path-to-jdk][/xml] option.

Nope, same error :frowning:

this is the problem when the developer of jmp uses a mac :P, it neglects 99.99% of the userbase :(, and the other 0.01% fly around on magical kites, high up in the clouds and live in a dream world where everything is perfect :roll:

I wish JDK 6 worked on my mac, or I would install it on my Mac in a heartbeat!

Seriously, I never messed up my windows install as much as some users apparently do… And I have a Windows 7 machine with JMP, a very clean one only for one audio app normally. jMP runs, installs and updates fine on that. Please get over the fact that you cannot afford a mac.

@ajwgeek: Are you sure you specified the path to the JDK and not the JRE?

I can afford one :slight_smile: (and own one) I just like windows for development better, since its what most users will be using, so its easier to test bugs. Any other suggestions?

Yes, and now I am confused because it is now saying the JRE was not found? If it needs a JDK, why look for JRE?

heh while its true I can’t afford one, its not the reason I don’t use it :). I already own a paper weight thx :slight_smile:

Uh seriously? When you point to JDK it complains “no JRE” and when you point to JRE it complains about “no JDK”??

Yes… If you want screen caps I can show you if you don’t believe me

@wezrule, maybe we meet for a beer for this discussion instead of messing up other peoples threads…

@ajwgeek, I have no idea how I could help you, does NetBeans install on your computer?

I have both netbeans and Eclipse installed, both working fine

Can you show me the line you entered when you tried running it with --javahome for the JDK?

cd ajwgeekDownloads

jMonkeyinstall.exe --javahome C:javajdk1.6.0_27

:open_mouth: my slash didn’t show up