JME3.2.2-stable-sdk1: Running program opens Terminal window

Hello together,

while working with JME3.2.2 on my Mac I found that running a program always opens a terminal window which remains open. I would like to hide/switch them off. How can I do this?
Using Java 1.8.0_202


Can you show this Window? And does it occur when running your game or the SDK itself?

1 Like

Yes, it occurs every time when I run my prog. It looks like this:

Looks like it is unable to open the SDK at all? Is that the case?
Are you running the mac version (.dmg) or the .zip?

I have installed the dmg version. I was wondering because running eclipse doesn’t have the problems. But the program runs and finishes correctly. Only the window remains open and I have to undock it from the dock every time the program shuts down.

I think I will download the .zip version and see how it behaves.

Well to me this looks like the invocation of java misses the parameters and fails, hence “exit” isn’t executed, for some reason. Could be that it broke in one of the updates. So it’s our/netbeans fault somehow.

Zip Version lacks Blender and JDK bundled, so it will run the system JDK/JVM, I was expecting the issues the other way (with the platform independent zip rather than the dmg)

Maybe this could be helpful but I found out that this behavior only occurs at least if:

  • a jme3 window is opened
  • a JAvaFX window is opened or
  • a Swing JFrame is opened

With console based applications (Logger.getLogger()… or System.out.println())
there is no problem.
Update: I have exported a jar project from the relevant project. Everything works fine. There is no window remaining open after closing the program.


Its me again :slight_smile:
I have just downloaded an older version of the SDK. v3.2.1-stable-sdk2 does not have this issue so it is likely an issue with 3.2.2.

Update: Sorry but I just restored the behavior on 3.2.1 by opening a jme3 scene. Don’t know why I didn’t see yesterday but it is present.


Hello guys once more.

I could manage to work around myself by switching the dock setup not to show the last opened programs in the dock. So I do not longer see them.

For me this is a solution I can live with at the moment.
But the question still remains why NetBeans behave that different at this point. Maybe it always had been like this but this feature of showing last opened programs has been enabled/added to macOs after I paused my work last year.