JME3 breaks when resizing a jme3 swing canvas after adding a Bloom Filter

this occurs when I tried using a Bloom filter, and it occurs everytime.

everything is fine until you resize the frame.

I can get it to occasionally fail just by adding an empty FilterPostProcessor instance (no filter assigned).

to repeat:

use the

in SimpleInitApp add:


FilterPostProcessor fpp=new FilterPostProcessor(assetManager);

BloomFilter bf=new BloomFilter(BloomFilter.GlowMode.Objects);




then inside the anonymous run() method modify these lines (so that the resize events are sent):


  • JPanel panel = new JPanel(new FlowLayout()); // a panel
  • JPanel panel = new JPanel(new BorderLayout());

    -panel.add(new JButton("Swing Component")); // add some Swing

    +panel.add(new JButton("Swing Component"),BorderLayout.SOUTH);


    the jme3 main loop appears to remain running, no errors are thrown but rendering ceases to update properly. text is

    written properly in the newly resized space, but it isnt cleared so trails remain. other Objects dont update at all.

I made a lot of changes lately with filters and resizing, did you update recently?

The only one that still fail to resize properly, to my knoledge, are ssao and cartoonEdges

EDIT : yeah I tested your test case and it works fine now, update to last SVN and there shouldn’t no problem anymore.

ok, so I just updated to the latest in svn and now with the bllom filter added all I get is this:

Framebuffer object format is unsupported by the video hardware.

com.jme3.renderer.lwjgl.LwjglRenderer setFrameBuffer

SEVERE: Problem FBO:

FrameBuffer[format=1272x885x0, drawBuf=0]

Depth => BufferTarget[format=Depth]

Color(0) => TextureTarget[format=RGBA8]

I cant use it at all now, resize or not. any ideas?

also some hints on what the new RawInputListener methods are for would be helpful.

public void beginInput();

public void endInput();

i wish I’d spotted this thread before (my bad for checking the forum without logging in first I guess).

related thread here

mhhh, make sure there is no other opengl application running on your computer, this FBO issue can occur in that case.