jME3 "Hello Node" Tutorial Issue

I’ve just recently begun the use of the jME and, while going through the tutorials, I have encountered a problem. The second tutorial, “Hello Node,” has code for me to test. The end result should be two colored cubes separated at an angle. However, when I run the code (using the jMonkeyPlatform) I only see one blue cube. I believe the error may deal with this line:

“WARNING: Uniform m_VertexColor is not declared in shader.”

If anyone would please help me to discover how I can fix what I believe is an error on my part, I would be very grateful.

The warning can be ignored, its not important and its cause should be removed really. If you see only one cube and dont get any other warnings or errors then maybe you do not attach the second box or place it incorrectly?



Thanks for replying.

I do not believe it is attached incorrectly, for I copied and pasted the code directly from here and checked within the code to make sure that it was connected.

However, after further investigating, I discovered that if I right-click on the file within the package and select “Run File,” the two cubes appear; if I select the “Run Project” green arrow at the top of the jMonkeyPlatform, then only the blue cube appears again.

Are “Run File” and “Run Project” different within the jMonkeyPlatform? And if so, what does each one do/accomplish?

“Run File” falsely runs the version of the test that is included in jME, this is a bug. To make sure your test class does not overlap with the internal class, rename the package name of your test class.

Tried renaming the package, but to no avail. :frowning:

Any other methods to be able to view the two cubes?

Just realized what is going on.

When I first create a package, the “mygame” package has a “MyGame” class already within it. Therefore, when I “Run Main Project,” this class is always the one showing up within my window. This holds true even when I create a different class within the same package. Plus, I believe this would make your (normen’s) post from earlier as a solution to the problem, but then renders the “internal class” as useless.

Questions now: is there any way to switch what the platform considers the main class to another class? If not, is the only way to test individual classes, without changing the package name, through the “Run File” I had mentioned previously? What is defined as an internal class?

(Sorry for the noob questions :))

The main class of the project can be set in its properties, under “run”.