JME3 on Rasberry PI

Is there a set of instructions on what to do to get JME3 running on a Rasberry PI 2 Jessy setup? The plan is to develop on a normal linux laptop and port the jars across. I don’t have a depth of knowledge to figure this out and got stuck with the lwjgl libraries being extracted and being ia32 instead of arm. The raspbian images have a lwjgl set of libraries but not sure what is required to get jme3 to use those instead of the internal ones. Goggle not returning much help.



I don’t know if it will work, but try manually placing LWJGL’s arm .so files with the JME jar and see if it works. If it doesn’t try removing JME’s LWJGL natives jar from the classpath and just using the arm versions instead.

There used to be a port for Raspberry Pi, but I don’t think its maintained anymore.

Also, now the Raspberry Pi OpenGL driver is standard (it used to require a lot of hacks to use within an application).
If you’re using the new driver, you should be able to build LWJGL targeting ARMv6 and use it within jME3 or any other LWJGL application.

had already tried removing the jME3-lwjgl-natives.jar from the classpath and copied the to the cwd, but was getting:-

java: symbol lookup error: /home/xxxx/ undefined symbol: JAWT_GetAWT

It looks like one of the jars needs to be updated to keep in sync with the jni so module. Will do further research

You should be using LWJGL3, not LWJGL2.
AWT / Swing is not available on the Raspberry Pi AFAIK

Didn’t know there was a difference or in fact you could select a flavour. Even more research required then. :frowning:

Sorry, are you saying that JME3-lwjgl-natives contains lwjgl3 whilst I installed lwjgl2 in raspbian and tried to use that.

Would it be best to obtain the source of lwjgl3 and build on the pi and attempt to use that?

I am pretty sure LWJGL3 builds for Raspberry Pi are not available, so yes, you would need to make one yourself, either on the RPi or via a cross-compiler.