Jme3-Voxel Issue

I am having the same issues as posted here:

The paging test located in the doesn’t work correctly. As described in the previous forum post, when you look at a mesh generated by the voxel engine, it disappears and another mesh that was next to it appears. It’s as if the engine is deciding which mesh to show based on where you’re looking.

I tried all the suggestions in that other forum post about the paging test issue, but none of them worked. I don’t know if it’s a tangent issue or what, but I looked through the code several times and can’t seem to find an issue.

Nevermind… I found the issue.

For those that care: It was in the extractor classes, it cleared all the meshes created with the generator every time it loaded. However, instead of correctly unloading the meshes, it simply just cleared all the array lists, thus removing the data itself without any errors. This is why it was difficult to detect.

I don’t know why the coder would want something like that for a paging test, it was a headache to find.

Also, the paging test was adding and removing things from the same node. Go figure.

hi what exactly is Jme3-Voxel, trying to access this link:

I get:

403. That’s an error.

Your client does not have permission to get URL /p/jme3-voxel/ from this server. That’s all we know.

Where can I find more info about it?

Every now and then Google Code goes into maintenance mode but if I remember correctly, those are usually read-only and on Tuesdays…

This it just not working at all… on a Thursday :slight_smile:

Maybe the project was deleted?

I don’t know if it was deleted, ask phate666, the coder of it.

Jme3 Voxel was basically a marching cubes algorithm, a mesh generator, and a perlin noise generator put into an API-like format.

Just be aware, if you ever get access to the code to this, there are more issues then I originally saw with the code in this, probably because it was unfinished. There are a lot of unforeseen bugs in it, such as the bug where you cannot add multiple textures to the meshes it creates. If you do so, it doesn’t render the second mesh created.

Another bug is the paging test. Even though adding multiple meshes by modifying the file, it still doesn’t work with the It isn’t an issue with the ChunkLoader or anything like that, I think it is in the SurfaceMesh class, where the meshes are generated. I couldn’t find anything, as I’m new to voxels in general (I’ve always used things like heightmaps and models for caves), so unfortunately I could never find the issue with it.

Due to all these bugs and me not being able to solve the issues I had with it, I had to stop using it altogether. I used Cave3d’s Marching Tetrahedrons instead, along with my own generator class, ChunkLoader, and Simplex Noise. When I saw that it was able to correctly render and load all meshes, I knew it wasn’t a problem with JME3, but with SurfaceMesh.

Oh, and by the way moonkey, I also looked into your voxel starting kit. I took the CreateWalls method, if you don’t mind. It proved particularly useful. :wink: