JME3 Zip Locator unable to find zip file

First up, my project is on Android (but that’s I think irrelevant to this question) . I have my blender-ogre output - .mesh.xml , .material, .scene. I put them in a directory “blenderfiles”, and compressed this directory using Winrar, to “”.
Then I placed it at the root of my JME3 project - the same place as src/, assets/ etc. Inside this zip I have “GrassPlane.scene” that I need to load. The zip has all other files to - texture PNGs, materials, .mesh.xml

Then , I used following code:

Spatial Ground = assetManager.loadModel(“GrassPlane.scene”);

But I get the FileNotFound Exception, saying , / : no such file or directory.

I tried adding this zip under mobile/ directory and also under nbproject/ but to no avail.

Is there something I’m missing here?

Thanks for the help,
Sanjeev Mk

I’m wondering why it says / and not just

Also, ZipLocator expects GrassPane.scene to be in the root of the zip file, not in a subdirectory.

That your project is on android is relevant and you should just unzip the assets in the assets folder, they are packed, no worries.

1 Like

I’m able to load the scene when I convert the .scene fie to j3o and put it under the Scenes directory under assets. But I’m still unable to load it if it is zipped. ZipLocator is unable to locate the zip. I tried placing it under :
Root of Project, Mobile/ , RootOfProject/Assets , Mobile/Assets

I keep getting the “/zipfile not found” exception

Sanjeev Mk

Thats because the zip isn’t there, especially on android. Why do you want to make a zip?