JMEDesktop Rendering problem

First off I

Could be the driver. Probably it reports other flags and causes texture setup to be wrong.

Try to change TestJMEDesktop to use a screensize of 512x512. This would sort out non-pow-2 problems.

Thanks for the reply Irrisor,

You were spot on, the culprit was the graphics drivers. I rolled them back (to a version released a month or two before) and everything worked again.

Just for reference, I encountered the problem with drivers downloaded from the ATI site for the… x1950Pro

Details from ATI site:

  Driver Version 8.9

  Release Date: 17 September 2008

Displayed in Device Manager properties as:

  Driver Provider ATI Technologies Inc.

  Driver Date 20/08/2008 

  Driver Version: 8.530.0.0

I've not got the time today, but I'll try reinstalling the drivers, setting the JMEDesktop to 512x512 and do the testing tomorrow, then I'll let you know the outcome.

Well, after finally getting some spare time I've tried running the JMEDesktop in 512x512 and low and behold it works! (also tried with other base2 256x256 & 1024x1024)

Is the solution to this problem to enforce the dimensions of the JMEDesktop to be a power of 2?  (have played around with sizes, one issue I can see with this is when the window is not a power of two, the positioning of components onscreen doesn't seem quite right)

Or is there a more elegant solution to this problem?

JMEDesktop should use pow-2-sizes automatically when needed. If the driver reports to support non-pow-2 it believes that :stuck_out_tongue: (it seems your new driver reports to support them but actually does not)

So you should be on the safe if you use a pow-2 size for JMEDesktop. If that's ok for you just do so.

Ah, so I now have a graphics card that thinks it's better then it really is …wonderful.

Forcing the use of a power2 size for the JMEDesktop sounds like the way to go with this one.

Thanks for the help  :smiley:

I get some serious corruption with the desktop objects. I also have an ATI card. My post.

What version of the ATI driver DOES work?

I’ll try downgrading the driver, but if you can tell me the internal version, that’d help a lot.

BTW… there’s 2 version numbers. The version for the download which is 8.X usually… then there’s the internal version which looks similar but quite different:

Looked at your post, an interesting problem, it could be down to the wonderful x1950 drivers.

The last set of drivers that worked correctly on my x1950pro:

            Version: 8.8

    Release Date: 20th August 2008

Internal Version: 8.522

I frequently updated the drivers, although I can't say I tried them all, the September ones are definitely when I encountered the JMEDesktop problem (got a new card in October, so that was last update on the x1950pro drivers).

Setting the JMEDesktop to a power of 2 did solve the problem with the September drivers. Does it make a difference with your problem?

I have to rethink how we handle input as it's probably the wrong and complicated method… so i can't currently use InputHandler… which JMEdesktop needs. I might fake it for now and see if power of 2 fixes the issue…

I might try downgrading the drivers, if that works, i'm gonna file a ticket with ATI itself and show them, that the drivers are what screwed it up.

Awesome about 8.8 though… was gonna go all the way back to 8.5 :slight_smile: