jME's native libraries are missing after reinstall

After I reinstalled the jMonkeyEngine I opened one of my projects and got many library missing errors. It seems as all the libraries that are normally there aren’t there anymore. This happened to all the projects that were created before the reinstall. New projects behave as common.

Both the projects and the engine are in the same folders as before.

What can I do?

The libraries listed in that project are those of the 3.1 alpha release, maybe you installed the 3.0 stable version?

Thanks, unfortunately it didn’t solve the problem: Before the library node was full, now it is completely empty. It doesn’t matter if I have version 3.0 or version 3.1 installed.

Whenever I create a project and reinstall the engine, all the libraries dissapear :confused:

If you’d like to know why I reinstalled the engine: I have a tool that makes a portable version out of every program, at least they say so. It makes a system snapshot before the installation and then one after the installation and compares both. Therefore I needed to reinstall the engine.

That’s a bit of offtopic though - the projects should still work after a reinstall. If you have further ideas let me know.

You can not open a project made in 3.0 with the 3.1 SDK or vice versa without it affecting the project files. It seems you have made up- and downgrades and not re-installs.
I think the simplest solution is to create a new project and move your source files into that project.

Well I think you wouldn’t need such a complex portable thing, just Copying the SDK Folder (as it even comes with it’s bundled jdk) seems to be enough.

On the other hand it’s very easy to fix the libraries and you should learn about it as soon as you want to switch to native bullet or strip unnecessary things out aswell.

In your first screenshot, simply click on Add Library and see if there is something jme related (I can’t recall the actual names nor find the related wiki page, though) which you could add (Usually there is some JME Main thing with all those libraries and then there might be another Desktop package) to your project.

Of course you need to remove the missing ones.

Alternatively you could go on edit for each missing lib and select the path where they are located (somewhere in the sdk, maybe under jdk or dist or lib).
Note: If you are already using the portable version this could be the problem: The library path is always changing.

I’m splitting this and maybe create an extra topic for the portable subject. Some people here are already confused.

So what I did in this order:

  • I worked with a stationary jME on my computer (unfortunately I don’t remember the version).
  • I reinstalled the stationary jME 3.0 on the same path as before and stored the projects in the same folder as before.
  • Then libraries were missing.
    Here I opened this topic to get help.
  • From normen I got the advice to try 3.1.
  • So I deleted that and installed version 3.1.
  • It didn’t solve the issue.

So far the progress of this topic. No portable jMEs are involved here (that was only offtopic), only the steps that I mentioned above. I deleted jME once - and first installed version 3.0 and then, following the advice, version 3.1.

PS: Notable is that I don’t remember with which version I worked before all that happened.
Now I’m going to try to fix the libraries manually. Thanks!

  • I again switched to jME version 3.0 and going to stay on this version until I’m a more advanced user or I need a feature of 3.1.

Now this is confusing. In 3.0 before upgrading to 3.1, I created an empty new test project “BasicGame_new”. Now that I’m on 3.0 again, this project is just fine with all the required libraries in there.

Maybe I really did something wrong when I reinstalled the engine.

I’m going to try out @jmaasing s advice to create a new project and copy the sources into. The manual library fix didn’t work well. I found and added all the as missing displayed libraries and the libraries-missing error doesn’t show up any more, but as soon as I want to build, I get other errors that don’t make much sense. Thanks you all :sunny:

This is the problem:
3.1 requires other libs (or at least they have been renamed) as 3.0, so you can’t use projects on 3.0 and 3.1 without redoing the libs each time.

Regarding your choice of 3.0:
Personally I also use 3.0, so I know that it has to be my code, when something bugs (and not the engine)

Other than that, there is nothing wrong when using 3.1, since there are many under-the-hood fixes (For example: Fixing crashes when importing Models(!), Performance Improvements, etc) and it would help the devs to fix them.
Using 3.1 is not really more complicated, it’s simply a new black design :smile:

Edit: Now I see your Edits: What is said wrong? The “Copy sources” method will work, but is a bit more effort than changing libs.

Possibly it’s something with lwjgl renderer or no renderer found as error which means you don’t have all the jwgl-natives etc files as your lib.

Clever trick: Create a new project, see what it’s libs are, note them and apply them. (jme3-lwjgl can contain jme3-lwjgl-natives.jar jme3-lwjgl.jar and lwjgr.jar or something, have a look)

This is the build log:

ant -f "D:\\...\\jMonkey Projects\\LearnProject" clean jar
Updating property file: D:\...\jMonkey Projects\LearnProject\build\
Deleting directory D:\...\jMonkey Projects\LearnProject\build
Building jar: D:\...\jMonkey Projects\LearnProject\build\assets.jar
Updating property file: D:\...\jMonkey Projects\LearnProject\build\
Created dir: D:\...\jMonkey Projects\LearnProject\build\classes
Created dir: D:\...\jMonkey Projects\LearnProject\build\empty
Created dir: D:\...\jMonkey Projects\LearnProject\build\generated-sources\ap-source-output
Compiling 1 source file to D:\...\jMonkey Projects\LearnProject\build\classes
warning: [options] bootstrap class path not set in conjunction with -source 1.6
1 warning
Created dir: D:\...\jMonkey Projects\LearnProject\dist
Copying 1 file to D:\...\jMonkey Projects\LearnProject\build
D:\...\jMonkey Projects\LearnProject\nbproject\build-impl.xml:981: The following error occurred while executing this line:
D:\...\jMonkey Projects\LearnProject\nbproject\build-impl.xml:825: copylibs doesn't support the "excludeFromCopy" attribute
BUILD FAILED (total time: 0 seconds)

I remember that fault in some way, I guess this is related to the fact that the build file is 3.1 and you are running 3.0 or vice-versa.

Then I guess you can only recreate every project :confused:

It’s not that bad. I haven’t done too much in jME right now, I’m only learning and testing out many things. I only have a few projects. So that should be managable for me.

Thank you for your help!