demo wont run in os x 10.8.2

Hi I have os x 10.8.2 for desktop and I am using jre7u9 the latest java version. When I try to run the webstart application demo for jme it opens the demo list window and when i open a demo it launches settings but when i hit ok on the settings window nothing launches no window, niether in full screen mode i dont know what causes the problem.

Does anyone have this problem too and have fixed it?

I really want to run jmonkeyengine on my mac.



Java7 on OS X is not supported for the moment. There is a problem with the underlying bindings to OpenGL (LWJGL) that is not resolved yet, and that problem is out of the jME devs control.

Your best bet for the moment is to install java 6 on your machine. (I run java6 and jMonkeyEngine just fine on my mac).

kwando do you know where to get jre6 for 10.8 i cant find a good download place on the net.


I would guess somewhere on apples website… but it can be a bit tricky to find what one is looking for. Maybe @normen are better updated on the subject?


I downloaded from here and installed, then added it to Netbeans, now I just have to set it in the project properties to use it and they work.

Hope that helps, only issue is I cant seen to make it default… unless maybe I forcefully remove jdk1.7…

Yeah, I just set my jdk7 folder to “read only” when I want to use 1.6