JMonkeyEngine installer doesn't work for me

I tried installing complete JME SDK, but when I click on the installer nothing happens. In the task manager I can see installer process pop up, but it closes in a second. I don’t see installer window, no errors, no dialog boxes, nothing. What could be the problem? I can extract files from the installer, but I don’t know what to do with those files.

Make sure you have the sun java jdk installed.

I have JDK, but I’ll try reinstalling.

Try to run the installer as admin.

I tried. Also, I tried all compatibility modes, but it didn’t help.

That’s weird… are you able to install NetBeans? They’re based on the same installer, so knowing this would help narrow the problem…

Okay. So I reinstalled JDK, it didn’t help. And I just tried installing netbeans, it doesn’t work either.

Btw, I use Windows 7.

How many decades have your windows xD?

It works fine on emulated Windows XP machine on VirtualBox, but I’d rather not do 3d programming on emulated machine.

I’m programming with the SDK on windows 7 right now and it works like boss.

I think it’s definitely your jdk that is the problem. Does eclipse work?

Eclipse works fine. And I just reinstalled JDK. I noticed that JAVA_HOME was pointing to old java jdk so I changed it, but it still doesn’t work,.

Does the Path envinronment variable have the newest java path set? Properly unninstall all jdks and the SDK via control panel, and use ccleaner to remove the registers. And after that install the jdk, and then the SDK. What is your jdk?

7u2 and path variable doesn’t have java path set. Do I have to set it to main JDK dir?

Yes. My Path is so:


C:Program Files (x86)CollabNetSubversion Server;C:Program Files (x86)NVIDIA CorporationPhysXCommon;C:Program FilesCommon FilesMicrosoft SharedWindows Live;C:Program Files (x86)Common FilesMicrosoft SharedWindows Live;C:windowssystem32;C:windows;C:windowsSystem32Wbem;C:windowsSystem32WindowsPowerShellv1.0;C:Program FilesBroadcomBroadcom 802.11 Network AdapterDriver;C:Program Files (x86)Windows LiveShared;C:Program FilesWIDCOMMBluetooth Software;C:Program FilesWIDCOMMBluetooth Softwaresyswow64;;C:Program FilesJavajdk1.7.0binjava.exe;C:Program FilesPrimeSenseNITEbin64;;C:Program Files (x86)PrimeSenseNITEbin;C:Program FilesOpenNIBin64;C:Program Files (x86)Universal Extractor;C:Program Files (x86)Universal Extractorbin


I assume that installer should start either way if I have JDK or not and then just tell me that I don’t have java installed, but it doesn’t show up at all.

Ok. Then it’s a netbeans issue!

I tried setting it to java.exe, but it didn’t help. Now I am trying to do clean reinstall with CCleaner.

I found some old bug reports about netbeans installer not starting, but it was way in 2006. I think it’d be fixed by now and I am not using Vista.