JMonkeyEngine pipeline from blender problem

Hi I have a problem, I’m trying to make a very simple model in blender 2.63, and import it into the jMonkey Engine 3 SDK, my problem is, I’m not very happy about the way I need to do it, since I’m only able to get .obj(wavefile) objects into the SDK.



I understand, that all of this is quite difficult to explain my problem, so I have made a screen cast of my problem and uploaded it on youtube, and I hope I’m able to get somebody of you to help me with my problem :slight_smile:



The video is available here:

http://www.youtube.com/watch?v=hMK-nrqHMAY&feature=youtu.be



Some info, which might be useful for you to know that I use:


  • jMonkeyEngine SDK 3.0beta
  • Blender 2.63.0





    BTW.

    I was around, the forums and read that the .blend import should be supported from 2.49 and 2.5+ of Blender, so I would assume that the later 2.5+ would also work with 2.63 ?

I don’t think that jME3 beta supports Blender 2.5+ importing. You may need to update the jMP to stable.

Hi thanks for the answer :slight_smile:



but I according to this post: http://hub.jmonkeyengine.org/2011/11/13/jmonkeyengine-3-beta-update-ready-to-roll/#more-2399



I should already have updated my jMonkey Engine SDK to a stable release, by checking for updates and installing them.



But my startup screen still shows jMonkey Engine 3 SDK Beta, when I’m starting up, do you have any other way to get a stable release, if it isn’t by updating through the application ?

I’ve imported 2.63 blender models fine using both the latest beta and nightly SDK.



It all “just worked”… although in my case I was only interested in the mesh and uv mapping, not materials, animations, etc so I can’t speak for those.

Hi zarch,



Do you think you would be able to make a very short screen cast of you importing a simple mesh from Blender 2.63, and into the SDK ? :slight_smile:

Not right now. Really all I do though is:



Drag .blend file into project assets

Right click .blend file->Convert to j3o binary



That gives me the j3o. I edit that in scene composer to remove anything I don’t need and rename any meshes that got generated by splitting on materials. (Blender supports multiple materials per geometry, jme does not - so meshes with multiple materials get split on import).



I am using the latest nightly but from what I remember it also worked back when I was using stable.

I couldn’t get anything to work with 2.63, but after changing back to 2.59, everything did just work :slight_smile:

Try using the ogre importer. Everything is 100% working & supported there (to be honest I wouldnt touch the blender importer with a barge pole right now, no offence to whoever made it :D)