JMonkeyEngine tests are available in the Android Market


The first version of several tests for JME3 and Android is published on the Android Market.

Search for the application “JMonkeyEngine Tests” or just “jmonkey” and you should find it:

There are 8 tests and only 4 of them are working as expected right now.

Tests that are expected to work:

SimpleTextured, helloworld.HelloJME3, helloworld.HelloLoop, helloworld.HelloEffects.

It would be nice if we got some responses about which tests from this list worked and the details about the phone on which those tests were tried.



SimpleTextured, HelloJME3, HelloLoop, HelloEffects work on Droid X, Android 2.2/2.2.1.


Today I went to BestBuy and installed the application on Galaxy S pad.

It worked!!!


Cool :smiley:

Anyone able to test this should submit their screenshots, camera shots and hopefully even some recordings in here so that we’ve got some visuals to show off for the blog update.

Hi Everybody !

I’ve tested the Monkey@Android Market on a tablet and on a phone:

  1. Galaxy Tab:

    Installation failed (Bad package signature). This should not be a big deal, I could check if you want. (See log dump below).
  2. Galaxy S:

    Installation OK. The four tests that should work work (!) well. The simple textured test runs at approximately 55/60 fps. I shot a video of the test (~30Mo MOV file). I can upload if anyone is interested (and if it’s possible, not checked with forum admin). I am not Ridley Scott, so sorry for the quality…

    I got this 2 platforms, develop on Android, know (and love) JMonkey (2 & 3) for a long time, so if I could lend a hand for dev/debug, my pleasure !

    Galaxy Tab installation log:

    D/vending ( 9307): [7] LocalAssetDatabase.notifyListener(): -4855801424212000518 / INSTALL_FAILED

    D/vending ( 9307): [7] VendingNotificationManager.showNotification(): Showing notification: [AssetID=-4855801424212000518, NotificationID=1371351185, Title=JMonkeyEngine Tests, Message=Installation failed]

    I/vending ( 9307): [7] MyPackageInstallObserver.packageInstalled(): Package install from content://downloads/download/22 failed: Bad Signature.
touchmypenguin said:(...) I shot a video of the test (~30Mo MOV file). I can upload if anyone is interested (and if it's possible, not checked with forum admin). I am not Ridley Scott, so sorry for the quality...
I don't get what you mean by "if possible" and "not checked with admin". We currently don't allow direct uploads of video; we rely on third party embeds from YouTube or Vimeo. You're perfectly free to upload your video to one of these sites, and it would be greatly appreciated!

touchmypenguin said:I got this 2 platforms, develop on Android, know (and love) JMonkey (2 & 3) for a long time, so if I could lend a hand for dev/debug, my pleasure !
We'd love that. Keep testing and post logs. If you have the time and savvy go ahead and submit patches as well.

Done. I posted a video of the “JMonkeyEngine Tests” running on a Tablet (Samsung Galaxy Tab)

(Poor quality but shows rendering and camera movements).

I only showed the 4 running tests:

SimpleTextured, HelloJME3 and HelloLoop: Good and flawless.

HelloEffects: Camera freezes after a few seconds.

If anyone needs more info, screenshots or videos please ask.

The installation from Android Market on the Galaxy Tablet fails, so I rebuilt the test as an unsigned package and upload it directly for the video.

Anton: How did you signed the package ? If you want I can check.

adb logcat said:

D/vending ( 4207): [7] LocalAssetDatabase.notifyListener(): -4855801424212000518 / INSTALL_FAILED

D/vending ( 4207): [7] VendingNotificationManager.showNotification(): Showing notification: [AssetID=-4855801424212000518, NotificationID=1371351185, Title=JMonkeyEngine Tests, Message=Installation unsuccessful.]

I/vending ( 4207): [7] MyPackageInstallObserver.packageInstalled(): Package install from content://downloads/download/28 failed: Package file was not signed correctly.

This is really cool stuff :slight_smile: What is a good Android phone to look at purchasing? I do not have one, but am considering on shopping for one :slight_smile:

Just given it a go on my phone (FroYo HTC Desire), but none of the tests did anything more than show a black screen. Is the source for the Android version online to try running it through with some logs to find what the problem is on there?

Any chance they will become available on 2.1?


We checked that JME3 works on Droid2/X (probably Droid1) and Galaxy S Tablet/Phones.

Also several people reported that tests do not work on different HTC phones.

I’m currently investigating what may be a problem.

So if you need a phone right now, go with Droid2/X/Galaxy S.

If you can wait, soon there will be dual-core phones.

Also, you can install tests from Android Market in the store where you are going to buy a phone and see that at least the first test works.


This is known issue :frowning:

According to logs that I get, there is no crash and I even see FPS reported, but nothing is on the screen.

You can build android part with verbose logging enabled (see OGLESShaderRenderer.verboseLogging property).

I see that right now there are several 1280 OpenGL errors (invalid enum constant). May be that is the problem.

Also, there were some changes in the regular LWGJL renderer that fixed some bugs. So I’m planing to port those changes to OGLESShaderRenderer and see. May be that will fix HTC incompatibilities.


Android 2.2 is a requirement for JME3. JME3 requires OpenGL ES 2.0 which is available on Android 2.2+.

On the other hand, I saw some people reporting that their 2.1 devices supported OpenGL ES 2.0.

You can try to run the tests and check the logs.


I used the standard android platform’s ant tasks to build and sign jars.

There is definitely a problem with installing the application from Android Market, if you have the application installed directly (with android market). It wont “upgrade” it and will complain during the installation.

Oh, i would definitely try, it’s just that it doesn’t show up in the market :wink:

It’s probably that the minimum api level is set to 8. Can someone upload the apk outside the market?

Yes, you can easily upload any apk. There is an option: Settings/Applications/Unknown Sources which should be checked.

The API level is set to 8. Actually, I don’t know how android market behaves towards applications that require higher API level when is available.

That’s what i mean. Apps that require a higher api level than your phone aren’t available, so i can’t see/download it. The min req api level must either be lowered, or the apk uploaded somewhere outside android market.

OpenGL ES 2.0 was only exposed to Java in Android 2.2, however you could already use it in C/C++ as early as Android 2.0:

In order for jME3 to support Android 2.0, we must use or create JNI bindings for OGLES2 using C++.

Tested today on my Droid 1 / Android 2.2.1

SimpleTextured, HelloJME, and HelloLoop all worked fine with minimal to no delay or glitches, and good responsiveness to touch.

HelloEffects appeard at first to lock the phone (black screen), but loaded after about 45 seconds to a minute with the falling rocks, and was pretty responsive to touch.

TestLightRadius takes over a minute to load, but finally does with a band of red gradient light and a small blotch of red above it. Its not responsive to touch, and appears to run at a very low framerate of 1 frame every few seconds.

TestSimplePhysics takes some time to load, and is not very responsive. Just a blue circle that sometimes haltingly moves around when you touch the screen.

HelloNode and HelloTerrain do nothing, or appear to temporarily lock the phone with a black screen.

1 Like

I upgraded to 2.2 today and tried the app on my Dell Streak. The app boots fine, but none of the tests work. All i have is a black screen, even on the four tests that should work.

Nothing seems to freeze the phone, though, a simple click on back brings me back to the selection menu.


Plz make at least a note at the TestChooser that there are problems with HTC-Phones. Don’t know

how you can leave it in this state for more than 2 Weeks. You know that there is an “unpublish button”

in the market?


I installed the apk on my desire HD today.

Tee menu displays correctly. Then when i select a test the screen stays black…


I can confirm fcalzada comments, the menu works like a charm lol but the test’s just provide a blacked out screen each test was left running for 5 minutes but nothing was displayed on screen :(.

Device: HTC Desire HD

OS Version: 2.2.1

Tests Passed : 0

Tests Failed: 8