JMonkeyEngine3 fails silently


I have windows 7 Ultimate sp1 x86, a 2.3ghz e6650 cpu, radeon 5670 gpu, and 4 gig of ram so my system exceeds basic requirements. I have 170gb free hd space.

I just downloaded the latest jme3 sdk and jdk from the links provided.

The first time through, i installed jme first, then java 6 - but when i run jme, the windows cursor spins slowly for about 2 to 3 seconds, then nothing else happens. There’s no error messages or anything, just a completely silent fail so I have no idea what’s wrong. I also tried running as an administrator, made no difference.

So I uninstalled both.

The second time through I installed jdk first, then JMe, and I still get exactly the same results … silent fail.

I searched your wiki for "silent fail’ “Silent crash” and “Crash to desktop” and got nothing.

I really want to try this as I’m sick of XNA and wanted to see if jme could be better…

Any ideas? I’m completely stuck, a silent fail gives me no angle of attack whatsoever …

What do you see when you run it form command line?

I hadn’t tried that so will do now …

ok still failing, but at least I get a message this time:

Your user directory (C:Program Filesjmonkeyplatform) cannot reside inside your

NetBeans installation directory (C:Program Filesjmonkeyplatform).

I made no changes to the default install path when i installed, so I wonder why that is a problem? Wouldn’t that then happen to everyone?

Tried installing to a different path. That doesn’t work either - lots of messages about being unable to find things …

So a default install isn’t working and neither is a non-default … wonder why no-one else has had this problem?

I don’t know what causes this but some people had this issue on windows, most solved it one way or the other…

Do you know how they solved it? I tried searching on the forum and in google but can’t find anything…do you have a link to someone else who had the problem?

Right now I’m considering a fresh install of windows because I really want to try this jmonkey looks nice…

No, sorry, I’d be happy if I did :(. If you care to poke around a bit more and see if you can find a real cause for this it would be cool, maybe you can also check :google: for some hints if NetBeans users had the same issues as we use the same installer base as they do. It might be some strangeness with the users home folder (say if the installer cannot write to the user home, it might try and set the user directory falsely to the application directory).

I searched the forum a bit more under “failure to launch” and found a Russian guy had the same problem. However, that was because he had Russian characters in his user name…and when he changed it, it was fine.

My user name is Jamie … no special characters or anything, pretty sure it should be Ok … :slight_smile: so that can’t be the answer.

What I’ve done so far is, downloaded and installed jdk6 as administrator, and downloaded and installed jme3 as administrator. I made no changes to anything and left all options as default, so no funny paths or characters.

Then I tried to launch it by double clicking the icon on the desktop… there wasn’t anything else I needed to do first, was there?

What’s this stuff about netbeans? Do I need that too? Or is just an alternative ide … in other words, have I done everything i needed to do and not missed anything stupid?

I see you’re the developer, kudos on such a great looking system, hope I’m not wasting your time with silly stuff…

I appreciate the feedback very much but I cannot really help you I am afraid, I have only one windows system and never had any of the mentioned symptoms. Its a pretty bare-bones and static installation though so its definitely not the “typical” windows install ;). This “your user directory…” thing was exactly what others reported but I never heard of a consistent “traceback” to the actual issue. :confused:

ok after a fresh windows install i installed jdk6 as admin and then jme3 as admin.

Now the error has changed! No more “user directory” errors - yet when i examine the directory structure, it’s the same as it was in the previous install. Strange…

The error message now is: lock (Access is denied)

Strangely, when I look at my hd, there is indeed a file called “lock” in the root c: directory… seems a strange place to put it.

Also, that file only has “read” permissions, no write. So I changed it so users have all permissions …

But I still get the same error!

Finally, if I delete the file, on running jmonkey it gets created again … still with only read permissions, not write !

I also changed the permissions for the entire jmonkeyplatform directory and subdirectories so the user has read+write permission…still no luck …

What’s the lock file for? Do you know a way around this error?

When you say you’re running the installations as admin, is your account an admin account or are you having to type in the admin username and pw everytime?

I’ve run into an issue with Windows 7 regarding running apps as admin from a non-admin account. If your account is not an admin account you may have to (at least temporarily) elevate your account privileges to perform the installation correctly.

No, I’m actually the administrator - it’s a single user computer and I have admin privileges. Thanks for the input though … :slight_smile:

I found the problem! It’s a combination of permissions and the wrong directory in etc/jmonkeyplatform.conf file !!!

What the problem was:

On windows 7 jmonkey installs itself to c:/progam files/jmonkeyplatform

But it sets the user directory in etc/jmonkey.conf like this:


So there’s a name mismatch in the installer - one part uses jmonkey, the other uses jmonkey3.0beta.

Secondly, it creates the lock file in the root directory - and it doesn’t then have write permissions. If you edit the file to give them, OR delete it entirely, it just gets recreated everytime with no write permissions - causing the access denied.

To fix:

  1. Create a directory on your desktop call jmonkey or whatever you like.
  2. Edit the etc/jmonkeyplatform.conf file, change the default_userdir section to default_userdir=c:/users/jamie/desktop/jmonkey

    Now it will work!

    Notes: (a) You MUST create a new directory for your files somewhere in YOUR windows user directory so that you always have the write permissions; putting it anywhere else risks windows screwing around with it. I put it on /desktop so you can see it easily.

    (b) Obviously in line (2) my user name is jamie, don’t forget to change to whatever your actual user name is!

    (c ) For some reason this forum deletes all the backslashes in posts. So where I used a forward slash in the directory names ( → / ) don’t forget to use a backslash instead.

    It’s now running fine for me.

    Thanks for your help Norden and feenqur!

The user directory is supposed to be at (home)/.(appname/jmonkeyplatform)/3.0beta… if thats not possible then really your home directory is not writable for you and thats kind of bad…

Windows 7 can be pretty annoying with permissions …

Maybe it would be better to change the installer so it creates a user directory on the desktop like I did? Easy for the user to find, and it works …

Anyway I struggled with this for 8 hours!!! Now I’m off to play with jmonkey … :slight_smile:

No, a user settings folder has to be in the user directory and not on his desktop (which is technically also in the user directory but surely no place to leave preferences ^^). As said, this normally works, its a quirk in your OS install.


Is this a ‘fresh’ installation of Windows 7? Or is this an upgrade from a previous installation (XP or Vista)?

I’m trying to narrow down what this issue might be as you really shouldn’t be having the problems you’re describing.


Did you move your user directory ? I had similar problems in that past after forcing “My Documents” to the root of another partition. Apparently Windows hates to have user documents in a root folder. Maybe you have a similar problem ?


Completely fresh. I was so keen to try jmonkey that i reformatted the HD and did a fresh install. I then installed jdk6 and jme3 before anything, even video drivers / antivrus etc (Because I wondered if maybe AVG was causing problems).


No. As described I did a full fresh windows install on hd (reformatted). My user name is just a standard 5 chars, nothing special. Did not move, play with or touch anything, just straight away installed jdk then jme3.

Yes, I’m pretty sure windows 7 doesn’t like documents on root folder. I noticed that when you attempt to run jmonkey, it creates a “lock” file but it is unable to then access its own file! If you delete it, it recreates it, again without full permissions (no write permissions). Taking over the file and granting it full permissions still didn’t work.

Ever since I moved the jmonkey folder to my desktop though I’ev had no problems, am going through the tutorials, everything looks good …