jMonkeyPlatform 3.0 stable freezes at 'starting modules' on Mac OSX 10.9.3

Hi All,
I’m trying to run jMonkeyPlatform 3.0 on my Macbook Pro running OSX 10.9.3, but it freezes at the ‘starting modules’ portion of the startup screen. I noticed that if I run it from a terminal as root (via sudo) it starts up and seems to run, but will freeze (spinning pinwheel, jmonkey platform listed as ‘not responding’ in force quit menu) whenever I try to change preferences, add shaders, or do anything that would require the project metadata files to be modified. I tried installing and running jMP on a MacMini also running 10.9.3 and I didn’t experience the ‘starting modules’ freeze but DID experience the project modification freeze. The only difference between the systems is the JDK version, 1.7.0_45 on the laptop where nothing works without root, and 1.6.0_65 on the MacMini. The logs state that both instances of jMP use a bundled 1.7.0_51 anyway, so I doubt that matters. Neither generated any logged errors, but I’ll attach the full logs from each just in case there is something useful I’m missing.

Here are the detailed system specs for each device:
Macbook Pro{
OS: 10.9.3
JDK: 1.7.0_45
Problem: jMP freezes during startup at ‘starting modules’ unless it is run as root from the terminal. Even then it freezes on project modifications
OS: 10.9.3
JDK: 1.6.0_65
GPU: Intel HD Graphics 4000
Problem: jMP freezes on project modifications

Any help would be much appreciated!

Macbook Pro Log
MacMini logs

linked to wrong log file for macbook pro; here is the correct one:
Macbook Pro Log

Today jMP is actually crashing during startup at the ‘done loading modules’ point. The log shows a null pointer exception. Not sure what’s different, but at least there’s an error message

macbook pro log with NPE

okay, I got the IDE to start by deleting the cache directory under ~/Library/Application Support/jmonkeyplatform/3.0/var. It still freezes during project configuration changes (basically any action taken in the left-most project elements tree panel), however. Here’s a link to latest log:
freeze during project config

by the way, I saw this post but I am only using one display so it doesn’t help.