jMonkeyPlatform auto restarting

I like jMP.



I don’t however, like that it restarts by itself everytime i try to shut it down.



It seems like the jmonkeyplatform.exe process keeps running after closing jMP, and launches the app again. Killing it solves the problem.

I’m running Windows 7 64-bit.

How do you close jMP? Via the Menu Item or via the “X” button or via a key combination…?

“X” button

And the other ways also behave the same way? It might be that the x button handling is broken somehow because its a system-specific event.

Closing through the menu yields the same result.

Strange… anything in the log? (Check the About screen for the location of the preferences and log)

I can’t say it’s doing that here. I just updated to check if I would get the same result but I don’t.



I’m also running Windows 7 x64.



Maybe an update that went wrong?

I noticed the same thing in both NetBeans and jMonkeyPlatform.

Sometimes after an update, when you click “Restart Now” it won’t actually restart. You would have to launch the software again, then it would apply the updates and close, and you have to launch it yet again.

I’m getting it right now. Not totally the same, but close.



It seems Project jME3 [0.6.0.6120 → 0.6.0.6185] doesn’t want to stick. I’ve restarted like 6 times already but it’s not working. Imports are now broken. :confused:

Took a while but it eventually worked… :confused: lol

Weird, weird… There were some fixes in the autoupdater lately, maybe these problems will be gone in alpha-3.

Actually, nevermind all that.



I had a couple of derelict explorer.exe processes running in the background and I do think those were why the updater wasn’t working properly. Maybe a lost thread hanging on… I don’t know.



Anyway, after logging off then back in the update went smoothly.



I know for a fact that sometimes explorer processes will be left running if you run and close a project several times one after the other rapidly. Like, Run (hit ESC), run (hit ESC), etc. At one point I remember having 4-5 processes running (my game) and with no way to close them. The STOP button was greyed out… That might be a cause.