jMonkeyPlatform configuration problem

Hello.



I just updated Netbeans, and jMonkeyPlatform through svn, so i’m not sure where the problem comes from, and would like some help (although it’s probably not due to jmp itself).



In the jmp properties, it says i have an invalid Netbeans Platform, pointing at “…/Users/UserName/.netbeans”. My various builds are there, but i’m not able to select any of them as platform.

When trying to build or run the project, it says “Cannot find NetBeans build harness.”. The properties are indeed specified in build.properties in the 6.9 folder.



I’m not too hot on these configuration issues and would appreciate some guidance on how to solve the issue.



Thanks

the harness.dir property has to be set n the private properties.

I cleaned out my jme-gde folder and reinstalled it, then did as you said. I got past that issue, then i stumbled into the next:



C:Program FilesNetBeans 6.9harnesssuite.xml:175: The following error occurred while executing this line:

C:Projectsjme3-gdejme3-project-librariesbuild.xml:7: The following error occurred while executing this line:

C:Projectsjme3-gdejme3-project-librariesnbprojectbuild-impl.xml:16: You must set ‘suite.dir’ to point to your containing module suite



I tried setting suite.dir to my jme3-gde folder in private.properties, but no luck.

I dont know, I would have guessed setting stiute.dir to “…/” would have worked… My private.properties looks like this:

user.properties.file=/Users/normenhansen/.netbeans/6.9/build.properties

That’s what mine looked like as well.

I’ve reinstalled both jmp and Netbeans but the problem persists. Something must have happened when i updated netbeans earlier. Since it’s not under svn control, i can’t do a diff either.



For now i’ve opened the project with regular netbeans, so at least i can work, but i’d still like to use the jmp features, so i hope to be able to solve it soon.



I’ve reverted all changes i made to the jmp files to use the latest from svn, and here’s the latest issue:



C:Program FilesNetBeans 6.9.1harnesssuite.xml:175: The following error occurred while executing this line:

C:Program FilesNetBeans 6.9.1harnessbuild.xml:57: When using cluster.path property, remove netbeans.dest.dir, enabled.clusters and disabled.clusters properties from platform config, they would be ignored.



There are no properties like that in my plaftorm.properties file.

Why do you build jMP yourself? Its updated nightly when you enable the nightly update center.

You know what? I don’t know. I hadn’t even realized there was a ready-made package. That makes it a whole lot easier.

Still have an issue with it, though. I can’t open projects, when i have selected the project folder, it says: “unrecognized project; missing plug-in?”, even for a test project i created inside this version of jMP.

Huh? Did you update it to the latest nightly? Tools->Plugins->Settings. Also, did you use the installer? This sounds like it cannot find the JDK, maybe you have to set the jdkhome in etc/jmonkeyplatform.config but the installer should have checked for that…

1 Like

Seems to have been a combination of both. Firstly it couldn’t find the jdk ( it was looking for a 32 bit jdk ), once that was sorted i could update properly and open the project. Problem seems to be solved.