JMP can`t open or create project

Hello, all.

Just download JMP and unpack it. Then launch and try to create a new projects, but after entering all names and paths for project just get "Opening project…" and application stop to responce. Terminate it and open once again, it tries again open project, but stop at "Opening SceneViewer…". Restart once again and close project before loading it in IDE. Then open JMETest projects still stops at "Opening SceneViewer…".

How can I fix it? Have installed NetBeans 5.5, if it is important, use Windows Vista.

Should I write path in such way: c:Program FilesJavajdk1.6.0_01bin ?

No, on windows you have to use double-backslashes. c:\my path\my file.txt


c:\Program Files\Java\jdk1.6.0_01\bin<br />

c:\Program Files\Java\jdk1.6.0_01<br />

Still have the same problem. Any other thought?

Uh, if it fails starting the SceneViewer already then its not finding the binary file. Click the little red symbol in the bottom right and see where it tries to find the binary, then extract it from the  lwjgl-natives.jar and put it there.

Hm, I don`t have any red symbol.


Did you see the SceneViewer at some point? Because you seem to have created a project and loading that seems to freeze the software before the error report can display… Maybe you should reset your settings, I dont know exactly where the folder is on windows, but I guess its somewhere in Documents and Settings/jmonkeyplatform or something. Just delete it and restart, then see if you can look at the error message.

In this way I have reached the error:

GLSL and OpenGL2 is required for…

The last text of error can`t scroll, because programm freeze.

After clicking on red dot in right bottom coner I see partly message about error LWJGL components.

As Far as I understand there is some kind of error with links. How can I fix it?

Seems like your graphics card does not support opengl2. Either you will have to upgrade your drivers or your hardware :confused:

Seems like you are right, I tried at my home PC - all works. But at work I have just Intel 946 Graphics. :frowning:


I installed jMonkeyPlatform and i'm getting this error too. This is the message:

GLSL and OpenGL2 is required for the LWJGL renderer!

I guess it is a problem with my graphics card, this is my device name:

Intel® 82945G Express Chipset Family

I upgraded my graphics card drivers and still getting the same error. Is there a way to fix this without upgrading my hardware?  $$$  :frowning:

Regards and thanks in advance.

You can get a cheap video card that supports OpenGL2. Any Intel card made after 2006 or ATI/NVidia card made after 2003 will support OpenGL2.

But you know, Ive uprgade my drivers to the latest and its working now.

GMA 945 graphics chip will not work with jme3 I think.

That makes a lot of sense as I can use JME3 on other (heftier) PC's. I would like to continue learning JME throughout Semester break while on holiday in Bali, therefore on eee. Is there significant difference between JME2 and JME3? That is can one use JME2 as a learning platform and easily transfer acquired skills to JME3?



I have a GMA 950 chip… so I guess I can’t use jme3 , huh?

reginaldford said:
I have a GMA 950 chip... so I guess I can't use jme3 , huh?

Afraid not.

Time for a new macbook. or I might get something good for linux…

I didn’t know my video card was using main memory the whole time! what a cheap move for Apple. The new macbooks have real video cards now though!

I have this GLSL and OpenGL2 is required for the LWJGL renderer problem too. I have the Acer Aspire One D250 with the Intel 945 Video Chipset. Current drivers are installed. What I did was started a new Basic Game Template, and without any changes to the template I ran the project. This is where I get the error. I believe my graphics drivers and hardware are supporting the GL2 and GLSL functions, so I do not understand the error.