jMP: Cannot find java

Hey guys, I’m having a bit of a fight with the computers at my campus. I’m not allowed to install stuff (but I am allowed to run the exe files afterwards, sigh) so I tried going with a portable approach (copy an installed version). Now, after updating all my modules became disabled and it was unable to find them or something. So I switched over to linux on the same desktop, which previously failed to start jMP halfway as it only had openGL 1.4. Turns out that my friend can run it on his laptop (also 1.4) so I wanted to give it another shot, removed the old version and installed a new one. All of a sudden it complains:

Cannot find java. Please use the --jdkhome switch.

Which is really weird to me as there is nothing wrong with my java install as far as I can see. Adding the path using the jdkhome switch has no effect, it just complains about the same thing. Any suggestions on what to do?

Just a small note on the side, I also tried using jME in eclipse but the files described in the wiki were not there in the latest nightlies, I wasn’ t able to find the jmonkeyengine3 jar in any case. Also, it would be nice to be able to download jMP for windows without an installer, just unzip and run. Any chances for this to happen?

Long story, but I’ve been fighting these machines for all afternoon now and no success. I think it must be possible to use them but I ran out of ideas.


Baal Garnaal

You need a JDK, not just a JRE. Also, use the parameter in jmonkeyplatform/etc/jmonkeyplatform.conf to specify the path rather than the command line switch.

The nightly builds contain only the engine jar files.

Thanks for the pointer to the conf file but it seems to have no effect. As for JDK instead of JRE, I am pretty sure I have the JDK and I doubt the problem is in there considering Eclipse does start and jMP also used to start, strangely not anymore.

Also, I was talking about this wiki: Guess that one is out of date then or something :wink:

Anyhow, I’ll give it another shot tomorrow, if you have any suggestions, please let me know =]

As far as I can tell, the jME3 jar is indeed in there :slight_smile:

Really, what the hell. I triple checked my downloaded file this afternoon and is surely was not there. Neither was TestChooser.exe, only the dirs were in it. It did take a rediculous time to unpack so perhaps those computers somehow messed up. God damn it.

Sounds like you’ve got a bigger problem than jME for the time being!!! Good luck getting it sorted out!

It might be possible that you downloaded a jME2 build. That one got me good the first time I downloaded directly from the nightly builds.

./applaud for ericlj, you caught me. I never expected to find nightly builds for jME in that folder so I didn’t beother looking at the first few letters, just the date. That would explain it.

Still fighting the java not found error, no clue what is wrong with this thing.