JMP not updating successfully after format

Just formatted my macbook recently and had to re-update everything. Fully updated the computer so I have opengl2.0 and java 1.6. But when I update JMP I get this on launch.

[java]Warning - could not install some modules:

CVS - The module named com.jcraft.jsch was needed and not found.

Native Execution - The module named com.jcraft.jsch was needed and not found.

jMonkeyPlatform Core - The module Java SE Projects was requested in implementation version “45” but only “46” was found.

jME3 Code Checks - The module Java Hints was requested in implementation version “4” but only “9” was found.

18 further modules could not be installed due to the above problems.[/java]

I’ve tried reinstalling clean a few times already. I know this computer can run it, it’s done it before, and it runs fine before the update.

Any ideas?

I just updated and it went fine, OSX 10.7, although not from clean Alpha-4. Maybe you have to temporarily disable the plugins and then update further, later enabling the plugins again if the consequent updates don’t enable them automatically.

Tried disabling all plugins and running updates. It found 4 and ran them fine. Then I enabled the plugins again. Everything was fine, but naturally it found 10 updates. Ran them. Same error. To give a bit more detail, after the bad update, roughly half of the plugins that worked previously are deactivated. If I try to activate any of them, for instance the IDE Platform plugin, I get:

Activation failed: Not all requested modules can be enabled: [StandardModule:org.netbeans.modules.ide.kit jarFile: /Applications/]

I’ve also tried running updates 1 at a time to see if a certain one broke it. Started with Local History. Learned my lesson.

Update centers: Base Alpha, SDK Stable, SDK User Contrib.

Any ideas?

Also, sorry for the double post. I would delete it if I could.

Ah I should also mention, now that the “bad update” has happened, if I try to close the program it gets relaunched right after. The only way I can stop the chain is by logging out of my mac or shutting it down.

I have the same problem with a number of plugins (including “com-jme-gde-core”). It’s been like that since the beginning of the week.

It seems it doesn’t update “com-jme-gde-core” even though it updates -libs, even if removing the .jar

I just reset my settings by changing the settings path in etc/jmonkeyplatform.conf and updated… No problems oO

Maybe I can go back to the main-golden build of netbeans tho…

@normen, CVS was one of the plugins that wasn’t updating correctly when we were talking last night… :x (Windows 7 box was the one giving me grief)

I have a similar issue too, no matter what i do my JMP is messed up.

it’s really strange it’s seams random, but not that random :stuck_out_tongue:

btw i can’t close JMP normally anymore or it restarts itself, i have to kill the process. Maybe it’s the restart procedure after updating that is messed up and not flagged as finished…

Yeah, somethings wrong on windows… @Momoko_Fan reported similar issues when updating the normal NetBeans 7.0 to 7.0.1 so maybe its really the netbeans platform.

I now put the main-golden netbeans build which is the same NetBeans that 7.0.1 uses in the platform update center, everybody who had problems try deleting the settings folder and updating again.

To make sure this came across: please give feedback!

Okay, I was able to reproduce the problem and now switched to the release branch of netbeans… Stay tuned.

Somewhat relieved that it’s not just me :stuck_out_tongue:

Ok, so I just tried a clean reinstall. Mostly because I’m not seeing any “settings” folder is on my mac. To remove JME each time I uninstall the Application and delete the folder …/Library/Application Support/jmonkeyplatform

I reinstalled and ran updates. Once running them all regularly at once, the second time disabling all plugins, updating, then updating only the Base IDE and Java plugins. Same problem both times :confused:

Side note, if it means anything, the first time the original error was thrown in a JMP box. The second time it’s being thrown in a Mac OSX error msg box.

Running OSX 10.6 btw. Not so sure about this thing running Lion.

You do have a settings folder at /Users/name/Library/Application Support/jmonkeyplatform

Hm, I guess the site went down right as I posted earlier.

I see jmonkeyplatform/dev/config.

Inside config there is a Preferences folder.

Also inside config there is a Windows2Local with a bunch of .settings files in it.

Does config == settings? Or maybe just Windows2Local? Or Preferences?

Btw, I ran across this:

The report shows the same error when trying to enable the disabled plugins. As shown at the bottom, this was due to the program looking in JRE 1.6 instead of JDK 1.5. I’m trying to see if I can trace JMP to see if it’s along the same lines, but I don’t have much experience with DTrace.

You can simply set a path to a defined jdk in the jmonkeyplaform.conf file.

Didn’t change anything :confused:

People who are having trouble with it in windows…have you tried running as administrator? Just wondering.

It is an actual dependency problem in all latest builds of netbeans platform, thats why I go back to the release version.

Glad for once I’m not in that list… Just updated jMP with ~24 new updates and only the GLSL refused to load.

Edit: It’s actually the jME3 Code Checks plugin.

Okay, the platform update center is reset to the latest release version and should give no dependency errors anymore.

1 Like

I had to trigger the nightly build of the SDK once to account for the changed dependencies but I am able to update from vanilla alpha-4 to nightly without hiccups now.