[Kinda Solved] jMonkeyPlatform 3.1 Alpha - can't run projects

Oddly enough I can’t seem to figure out the cause or manually recreate this, but it’s happened twice. I’ll start a new project with the 3.1 Alpha editor, do some work, then an arbitrary amount of closes/reopens later, I can no longer run the project. All the source is there, and the editor seems to be working fine (error detection, etc.), but all of the run, debug, etc. buttons are simply greyed out. I’ve tried rebooting and restarting jMP to no avail. Is this a known bug or could it be on my end? It may help to note specs:

Win10 Pro
480GB SSD on which jMP is installed

I have a similar problem even though I can start the projects again after a couple of restarts. Seems to be a netbeans problem though… Here is an answer that might work for you if restarting does not: http://stackoverflow.com/questions/25257032/my-netbeans-project-cant-run-or-debug

Deleting build.xml did not fix. I can’t do a Clean + rebuild, as that option is also greyed out.

The “rename project” button in the drop-down was greyed out, however I could still click the selected title and type a new name. Renaming the project this way, and checking the box that said “also rename project folder” appears to have fixed the issue. Hopefully this gets fixed soon, it’s gonna get inconvenient if this project grows in size…

hi,i sometimes face this problem,u can close the project and open other project, the run button won’t be greyed out,restart jmonkey,open ur previous project,and it will be runnable :smiley:
sorry for my english