Latest updates seem to have killed my platform


I just updated to the latest build and now when starting the environment I get an error pop-up with the following:


Error opening OpenGL window!

Your graphics card needs to support at least OpenGL 2.0,

if that is the case please download the latest drivers.

Error: com.jme3.asset.AssetLoadException: WireColor.j3md has been marked as obsolete. Please use Unshaded.j3md instead.


I did all the updates at the same time so I figure that any common material defs should have been updated too.

My graphics card is an Nvidia GTX580 and I was running slightly old drivers so I updated to the latet bleeding edge ones and it hasnt helped.

I can “OK” the error message and get into the environment but if I try to do anything OpenGL related it fails.

Any thoughts?


You can just click that error away and it will work as normal. Its due to the latest deprecation of the materials, a fix for jmp is committed already and should be in the updates tomorrow.

Downlaod the latest driver?

Also use Unshaded.j3md ^^

No, its the platform that uses the old j3md, he can’t do anything about it :wink:

OK so I have done that and I couldnt open my .j3o models without an error so I regenerated them from the source ogre files and now I can open them in the scene editor but my mouse controls for altering the viewing angle dont, neither does the wireframe view. The light button works but that seems to be it.

Will this also be fixed in the update tomorrow or is this a different problem?


p.s. Thanks for the ultra fast response!

Hm, I am running a build right now, so the fix should be available shortly.




The updates cleared the error messages but I still seem to have no mouse control for the viewport in the model viewer/scene editor etc.


Do you get mouse input in the tests? I think @Momoko_Fan changed something in the input.

If by that you mean if I run one of the test projects is my camera controlled by the mouse then yes that works fine. It just seems to be a problem in the editor.


Okay, I’ll check with him when he’s on.

Thank you.

Very much appreciated!


I found another use of the deprecated material, a build is running and the problem should be fixed with the next update.

Edit: Btw, theres a small warning sign in the lower right when an exception happens in the SDK, click it to see the exception stack trace.

OK so for a totally unrelated reason I just had to re-install Windows - oh the fun.

I re-installed JMonkey from the download on the site and then updated. Now when I try to open it I get the OpenGL error except it seems to be recursivly generating the same error over and over so I cant get into the platform to do anything!

Is this just me?


Hm, normally it checks for the error message and doesn’t display the error if it occurred right before but maybe the message is null… I guess you weren’t able to update completely due to some dependencies and that you could still update if you could log in… Does it display the error before the main window is created or can you select the menu to update somehow? Also do you see the warning sign to get a stack trace? The latest version runs fine for me.

No stacktrace.

It happens after the main window but either the errors are modal or it crashes and stops responding quick enough not to be able to perorm another update to fix it.

I will try uninstalling and re-installing and cross my fingers!


Yep going from scratch worked. No idea what went wrong but its OK now.

Thanks for all your help!