Latest version of jME3 has a shadowrender issue on android 2.3.3. Image demo incl!


I’v worked hard, tried the latest 3 nightly, installed after much work and TONS of downloads and help from this forum, managed

to install svn and then build it using ant 1.8.

Problem is, my rendering of the game is done weardly. It was like this before I used the never versions and it has not changed.

Except that I dont get a gsl 1820 error.

Here’s two images that shows how the shadows are renderd:

Here is what I see on the cellphone:

And here is how the shadows appear without a black background:

These are not screenshots, but demonstrations of what I see when I play my game on my phone.

One thing is interesting, when I look at a certain point on my planet, about the center of the base planet (the one with the rocket on)

then this error will disappear, If I look the slightest to the side it will appear again.

I load my materials like this:

[java]public static Material Color(ColorRGBA color) {

Material mat = new Material(MainGame.getAsset(), “Common/MatDefs/Light/Lighting.j3md”);

mat.setBoolean(“m_UseMaterialColors”, true);

mat.setColor(“m_Ambient”, ColorRGBA.Gray);

mat.setColor(“m_Diffuse”, color);

mat.setColor(“m_Specular”, ColorRGBA.Gray);

mat.setFloat(“m_Shininess”, 0);

//mat.setBoolean(“VertexLighting”, true);

return mat;


Enabling the vertexlighting does not help.

Any idea what this could be?

well actually , i’m kinda surprise it doesn’t crash…

Shadows are not supported yet on android

1 Like


Here I’v been! Trying to solve milions of problems just to get the lighting to work.

And then I get the news, shadows no work on android?!


Well according to your shot…shadows just looks bad on android, wich is a lot better than “shadows do not work”…maybe not.

If you feel adventurous, you can have a look at the pssmShadowRenderer and search for what’s failing, or…you wait until i get there, i’ll eventually look into shadows for Android, but there still a lot of things i have to do before.


+1 for shadow support on android, even simple ones