Lensflare too 'flarey'

I am implementing a lensflare into the main menu of my game and the scene is rather gloomy and the sun barely peaks through the clouds.  I'd like the lensflare to just gleam through but it doesn't seem like there are any settings to configure the lensflare to be less bright or smaller or anything else.  Is there any way I can do this?


Changing the scale doesn't seem to effect it at all. :frowning:


As you should have noticed while using the lens flare effect it uses images. Simply take other images :slight_smile:

I was afraid you were going to say that. :-p

I was hoping there was the ability to modify some settings to make manipulation easier, but I guess we don't always get what we want. :slight_smile:



Can't you scale it?

try setIntensity(float)

Was that always there?


It's been there for a long time…

  • goes to check his vision *

    Thanks. :o


Okay, well unless I'm doing something wrong (which I'll readily admit is quite likely) no matter what I set intensity to it doesn't make a bit of difference.

Oh, well, I guess it does do something:

public void setIntensity(final float value) {
        if (value > 1) {
            this.intensity = 1;
        } else if (value < 0) {
            this.intensity = 0;
        } else {
            this.intensity = value;

Apparently the only thing that method is there for is to enable or disable the lensflare.


hmm, it's odd that if it is greater than 1 he had it set to 1…  But did you try something like .01f?

Intensity sets the scale of the lensflare… or so it seems. Check the draw(Renderer) method of LensFlare.

looking at the lensflare.draw method, it seems that the intensity is used for setting the scale wich is correct. but further down in the draw method, if (rootNode != null) the intensity is set to 1 or 0, and if set to 1, it goes on with checkrealocclusion() wich sets intensity to something else again…so it seems that the intensity is not something that was intended to be public to the user(the method should be private)…probably should be added another parameter that is multiplied with the internal occlusion-bounded parameter when setting the scale…