Libodejava.jnilib on OS X


Whenever I run the physics tests, I get a OS dialog, stating that "The application com.jmetest.physics.TestMarble quit unexpectedly. The problem may have been caused by the libodejava.jnilib plug-in". I'm pretty sure I've set everything up correctly as per the tutorial on the wiki. Indeed, I've set it up on my laptop, and it works absolutely fine. Moreover, I've been searching for differences in how I've set the two up, and I can't find anything. I've even tried deleting it all and starting again a couple of times; to no avail.

All the tests from regular jME work fine, and even the Vehicle test from jMEphysics2 works fine. I'm assuming that's because it seems to have no actual physics in it(?), and the problem seems to be with the ODEJava library?

I'm using Eclipse (3.3), and I've got the most recent versions of jME and jMEphysics2 from CVS this morning. The computer is running 10.5.4, and is a PowerPC G5. My laptop (which works fine) is running 10.5.3, and is an Intel Core2Duo.

Thank you for any help…

Anyone? Somebody must have run in to the same problem, though!? Surely…

For TestTerrain this is a known issue. I did not get around to searching for the actual bug but it seems it's in the native ODE (GIMPACT) code for memory allocation.

But all other test should be fine.

No idea why it should be different in your case, sorry :expressionless:

is the ode native lib in jmephysics cvs the one that was recompiled for intel?

Yes, I think so. It should be a universal binary (intel+ppc).

Yeah, I've tried tests that don't use TestTerrain, and have the same problem… Is there anyone here on a PPC that can confirm that physics works or not? Because I guess that could explain it. It just seems unlikely that I'd be the first to run into the problem…