Light Bug

Well, there is a lighting problem. I don’t think it happens with everything, because I tried it with a block of wood and it worked fine. However, with these ramps, when I erase one, the one which was hidden doesn’t appear to recalculate the lighting, and stays black. But check the images:


There is plenty of those lighting mistakes and Paul is fully aware of em, don’t worry :wink:

Yeah, some time back I made lighting more efficient and introduced some bugs. My guess is that there is a tile (leaf is what they are called internally) boundary right there and that the light doesn’t properly propagate across.

I haven’t checked your coordinates against the Leaf:352, 448, 64 line to be sure… but that’s my guess. This may be one of the easier examples to create so I will try it myself some time. The other one I’ve consistently found so far requires me to construct a whole room. :slight_smile:

Ok. I use to create a fire light near the place when that happens, so it’s not a big deal, however I wanted to make sure that you known the bug. :slight_smile: