Lightspeed Frontier - Kickstarter AND Steam Greenlight!

I know I everyone is tried to death of seeing another LSF post, but as you can see this time it’s on! if you can be bothered to log into Steam, I’d really appreciate a vote :smile:

Or if you’re in a far more generous mood, there’s a Kickstarter campaign running in parallel:

Also there’s a brand new forum for the game at that also runs on Discourse which this forum really made me like :wink:

I’d like to thank everyone for helping me get my project this far, especially @pspeed for putting up with my hopeless useless questions time and time again, and @empires for being an awesome publisher.

Now I can finally rest after making gifs for days :relieved:


Congrat for this game, We’ve followed your project step by step, and it’s very nice to see it today ready to hit the shelves :wink:
Really impressive video, I wish you the best of luck for your greenlight and kickstarter :wink:

1 Like

I have liked :slight_smile:

1 Like

Thanks guys, I’m really excited myself!

Well it’s still a few months away from that, but no sooner than December and there might be Early Access before that :wink:

But did you fix the problem on linux? if you want to sell your game for steamOS, you will have angry linux users :wink:

Well for one it doesn’t happen on all linux distros (you were the only one to report it), but you have a point. I suppose I could update to Jme 3.2 once it gets stable enough but it’s a lot of work for a fix that we don’t even know for certain that works.

My friends had this problem on ubuntu 14.04 - 16.04 :slight_smile: but all my friends have only nvidia cards.

I thought all angry users were on windows …

My greenlight vote given.

1 Like

Congratulations for the campaign! I was eager to try it from you screenshots.
I’m having a few problems with the demo I downloaded.

First, the script isn’t encoded properly and I get the error

bash: ./ /bin/sh^M: bad interpreter: No such file or directory

I ran dos2unix on it and it made it work by removing that carriage return there.
That isn’t a big deal, but when I run it I get this

com.jme3.renderer.RendererException: compile error in:ShaderSource[name=assets/shaders/spinquad/Unshaded.frag, defines, type=Fragment, language=GLSL100] error:0:28(2): error: initializer of type int cannot be assigned to variable of type float

Full stacktrace
I’m on an Intel HD Graphics 4600 with driver version is 2.99.917 (latest according to Downloads |
I don’t know much about programming shaders but I could help you debug it if you want.

Sounds like a missing .0 somewhere. Must be developing on nvidia in compatibility mode (ie: no specific shader version, ie: older JME… maybe alpha2?)

1 Like

Usually, I test my shaders on geforce 750M, but when I started testing my shaders on Intel Graphics and nvidia 9xx, I had a lot of problems with my shaders ))

Yep, woking on a GTX 760 and 960M, so that’s often a problem for me. Also using the jme 3.0 version from a year ago.
I found this line:

float speed = 1;

and that probably corrects it?

float speed = 1.0;

I’ve uploaded the shader here, so you can test it out by replacing assets/shaders/spinquad/Unshaded.frag in the jar file.

I had another guy tell me something simmilar. So it needs to be all in one line?

#!/bin/sh java -Xmx2G -Xms2G -jar lightspeed.jar

If you don’t care about running on mobile and you are running an older version of JME like that then you can save yourself a lot of time by changing your j3md to have GLSL110 instead of GLSL100. The former is the first ‘real’ version of shaders and so will put the proper #version line at the beginning of the shader. The latter is JME’s ‘generic’ version and on old JME versions like 3.0 would leave the #version out. Only leaving the #version out puts nvidia’s drivers into compatibility mode since they worked before GLSL was ‘official’.

So if you change to GLSL110, nvidia will tell you about these errors, too.

1 Like

Oh, awesome! I’ll try that out.

Edit: Ok, there appears to be a ton of implicit casts to float. This’ll save me lots of headaches in the future.

You have got my vote! Good luck :four_leaf_clover:

1 Like

This just look amazing, first kick starter i ever supported :stuck_out_tongue: Lest hope it work! GL HF

1 Like

No, two lines is Ok, but without the CR character that’s confusing bash (shown as ^M).
You probably need to set something in your text editor to use unix line endings.
I can send you my fixed version by email if you want (I cannot attach it here).

Great sandbox spaceship game



I just fired it up today and the building spaceship part is really cool. But I’ve been hitting some bugs, what’s the best why to report you?