Linux 32-bit: Install wizard screen is blank

Running the installation .sh file brings up the install wizard window, but the window is completely blank. Nothing is actually displayed within in it, and you’re left with a gray background.

I ran the installation again, with --verbose. There were no errors, and there was some xml listed (which, I guess, was supposed to be displayed) so I figured that it was just a display bug, and went on to press Enter in the wizard window (even though I couldn’t see anything), hoping that it would just move ahead with whatever the default options happen to be.

The installation seemed to complete, and I had a jmonkeyplatform directory in my user directory. I went into bin and ran jmonkeyplatform. The little splash screen (with the little monkey) popped up, and things seemed to be loading, but I ultimately ended up with yet another blank window.

It’s really weird, because the underlying program seems fully functional. I mean, I can right click on certain areas of the window, and have some options pop up, but everything under that is just blank.

Here’s a screenshot:

I’m on a somewhat dated laptop (a few years at this point), running Arch linux, but I have a GPU that supports OpenGL 2.0 (and higher), along with enough processing power and memory to support many other, fairly sophisticated applications - So, it’s not a problem on the hardware side (or, I think it’s highly unlikely).

Any ideas?

Once I realized that the SDK is actually built on NetBeans, I was able to refine my search, and ultimately find this:

I tried simply exporting the variable, as advised there, but that didn’t seem to work (probably because it’s intended for OpenJDK, which jMonkey doesn’t use), so I used the alternative method (setWMName “LG3D”), involving a startup hook for my manager (which is xmonad).

Now it all seems to work fine.

1 Like