Linux Library Path

Oh no! Another linking problem! Hopefully, the last linking problem, too. I went through my own tutorial in Linux, and I got the error, following instructions exactly.  What was the solution to this? I tried it with and without quotes, and moved the .dlls around to try to make it work, but nothing happened. How can I fix the problem? My VM options were:


doesn't linux use  : instead of ; ?

Linux uses : instead of ; for path seperation afaik. Linux also doesn't use .dll but .so

You can also use the LD_LIBRARY_PATH shell variable.

As a last resort, you can put all the native libraries in the same directory where you run the program.

I tried with both : and ;…

Jedimace1 said:


Are you quite sure about this? "." means "current directory" in unix - you might want to try again without the leading period.

Tried that too, with and without quotes, with colons and semicolons, with and without the dots, with single and double quotes. I tried putting it in the directory of the .exe. Anything else?

Have you ever been able to let it work in Linux?

Perhaps if you try this:


with or without (single/double) quotes.

I works for me on linux (slackware 12.0).

What error messages do you get?

I've never had LD_LIBRARY_PATH fail on me either. Make sure you use full path rather than relative ones like you do there.